Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227665 - HTS: Submit phase doesn't cope with certain chars in vendor/make/model
Summary: HTS: Submit phase doesn't cope with certain chars in vendor/make/model
Keywords:
Status: CLOSED DUPLICATE of bug 229025
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 5
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 13:48 UTC by David Swegen
Modified: 2016-02-18 00:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 09:30:48 UTC


Attachments (Terms of Use)

Description David Swegen 2007-02-07 13:48:22 UTC
Description of problem:

Running the 'hts submit' phase, where any of the vendor, make or model infos
contain chars that have special meaning to the filesystem causes the rpmbuild
step to fail.

In this particular case the vendor was 'FUJITSU_SIEMENS //
Phoenix_Technologies_Ltd' (one long string). The spaces get replaced by
underscores, but the '/' chars remain, thus confusing various later commands.

This same problem will probably also be triggered by other chars, such as '&'. 


Version-Release number of selected component (if applicable):

hts-5.0-23

How reproducible:

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Greg Nichols 2007-02-07 14:47:04 UTC
Fixed R24

Comment 2 Danny Trinh 2007-02-09 14:42:00 UTC
So, does R24 fix the problem below also?

[root@localhost ~]# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
writing results to /var/log/hts/Dell_Inc.-TEAC_DVD+RW_DV-W58E-RHEL5_i686_results
copied attachment file localhost.localdomain.2007020912311.tar.bz2 for info test
copied attachment file localhost.localdomain.2007020912311.tar.bz2 for info test
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
    return self.doSubmit()      
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 369, in doSubmit
    if report.WriteResultsRPM(self.LogDirectory):
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 181, in
WriteResultsRPM
    self.WriteLogForRPM(testsByName[testName], runNumber, [byTestDirectory,
byRunDirectory])
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 221, in WriteLogForRPM
    log.write(outputLog)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xb1' in position
28970: ordinal not in range(128)
[root@localhost ~]# 


Comment 3 Greg Nichols 2007-02-09 15:36:58 UTC
Re: comment #2.  No, it does not.

Comment 4 YangKun 2007-03-07 09:30:48 UTC

*** This bug has been marked as a duplicate of 229025 ***


Note You need to log in before you can comment on or make changes to this bug.