Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227623 - scim-tomoe gives no candidates
Summary: scim-tomoe gives no candidates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomoe
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 05:10 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-07 10:28:29 UTC


Attachments (Terms of Use)

Description Jens Petersen 2007-02-07 05:10:33 UTC
Description of problem:
Recently scim-tomoe is not working for me on several machines.
I have tested on several FC6 boxes and rawhide.

How reproducible:
every time

Steps to Reproduce:
1. install scim-tomoe on FC6 or later
2. start it from the scim command menu
3. input a simple character like 人 by hand.

  
Actual results:
No candidates appear.

Expected results:
Candidates to appear.

Additional info:
I haven't tried to debug this yet.

Comment 1 Jens Petersen 2007-02-07 06:47:37 UTC
Okay I think I found a clue: if one installs tomoe-devel and libtomoe-gtk-devel
then it works for me again.  Perhaps some library .so symlink is being assumed?

Comment 2 Jens Petersen 2007-02-15 04:52:25 UTC
It seems libtomoe dynloads the unversioned modules
which were symlinks in the -devel package.

Comment 3 Jens Petersen 2007-02-15 05:46:31 UTC
Fixing in tomoe-0.5.1-1.fc7.

Comment 4 Hu Zheng 2007-03-07 09:59:07 UTC
/usr/lib/tomoe/module/dict/libxml.so
/usr/lib/tomoe/module/recognizer/libsimple.so

These two files are needed, if rename them, then libtomoe-gtk can't work.
I will dig this more later.


Comment 5 Jens Petersen 2007-03-07 10:28:29 UTC
tomoe-0.5.1-1.fc6 built for FC6 too.


Note You need to log in before you can comment on or make changes to this bug.