Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227611 - How does K3B do sample rate conversion?
Summary: How does K3B do sample rate conversion?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b
Version: 6
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-07 01:55 UTC by Jonathan Ryshpan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-09 15:27:26 UTC


Attachments (Terms of Use)

Description Jonathan Ryshpan 2007-02-07 01:55:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
When I build it on my machine, it uses libsamplerate, as evidenced by:

$ ldd /usr/bin/k3b | fgrep libsamplerate
        libsamplerate.so.0 => /usr/lib64/libsamplerate.so.0 (0x00000036a2400000)

When I do this on the version from a repository, I get:

$ ldd /usr/bin/k3b | fgrep libsamplerate
        <Blank line>

I've been looking through the objects and libraries in the various k3b packages to find out how they do sample rate conversion, so far without success.

The version is k3b-0.12.17-1.


Questions:

(1) Why does my build invoke libsamplrate.so, while the one from the repository doesn't?

(2) How does K3B as released from the repository do sample rate conversion?

Version-Release number of selected component (if applicable):
k3b-0.12.17-1

How reproducible:
Always


Steps to Reproduce:
1.$ ldd /usr/bin/k3b | fgrep libsamplerate
        libsamplerate.so.0 => /usr/lib64/libsamplerate.so.0 (0x00000036a2400000)


Actual Results:
Nothing

Expected Results:
        libsamplerate.so.0 => /usr/lib64/libsamplerate.so.0 (0x00000036a2400000)

should appear on the console.

Additional info:
I don't know if this is a bug.  It seems to be a problem of some sort.  I have reported it on the Fedora list.

Comment 1 Rex Dieter 2007-07-09 15:27:26 UTC
libsamplerate support is in k3b-extras (for FC-6).

This couldn't be included in the "Core" k3b since libsamplerate is in "Extras".

Life is better with F7 (and beyond) since Core/Extras are merged.


Note You need to log in before you can comment on or make changes to this bug.