Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227598 - HID causes BUG assertion on startup
Summary: HID causes BUG assertion on startup
Keywords:
Status: CLOSED DUPLICATE of bug 228755
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-06 23:33 UTC by Bastien Nocera
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 10:45:00 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-02-06 23:33:46 UTC
kernel-2.6.19-1.2895.fc6 on x86-64

I get plenty of those:
BUG: warning: (value > m) at drivers/usb/input/hid-core.c:793/implement() (Not
tainted)

Call Trace:
 [<ffffffff8026999a>] show_trace+0x34/0x47
 [<ffffffff802699bf>] dump_stack+0x12/0x17
 [<ffffffff803e9ef0>] hid_output_report+0x1b5/0x221
 [<ffffffff803e9fb8>] hid_submit_ctrl+0x5c/0x1f8
 [<ffffffff803ea349>] hid_submit_report+0x15f/0x18c
 [<ffffffff803ec9c8>] hiddev_ioctl+0x34f/0x8f8
 [<ffffffff8024032d>] do_ioctl+0x55/0x6b
 [<ffffffff8022ff2b>] vfs_ioctl+0x256/0x26f
 [<ffffffff8024a989>] sys_ioctl+0x59/0x78
 [<ffffffff8025c11e>] system_call+0x7e/0x83
 [<00002aaaaaf94147>]

On bootup. I have no idea what this is supposed to be, and happens after:
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts

and before:
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
...

The only USB input device on the machine is:
Bus 005 Device 008: ID 046d:0b02 Logitech, Inc. 
Bus 005 Device 010: ID 046d:c70a Logitech, Inc. 
Bus 005 Device 009: ID 046d:c70e Logitech, Inc. 

a "Bluetooth" mini-receiver from Logitech (a USB no wires adapter for kbd/mouse
combo that can switch to being a Bluetooth dongle).

Comment 1 Pete Zaitcev 2007-02-15 20:15:49 UTC
Bastien, this looks like a dup of bug 228755. Can you get me the full dmesg,
to see if hid2hci is involved? There should be a process name in it, I think.


Comment 2 Bastien Nocera 2007-02-22 10:45:00 UTC
hid2hci is definitely involved. It's the same hardware as reported at
http://lkml.org/lkml/2007/2/16/215

Thanks

*** This bug has been marked as a duplicate of 228755 ***


Note You need to log in before you can comment on or make changes to this bug.