Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227507 - clustat -x missing group information
Summary: clustat -x missing group information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
: 227547 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-06 15:16 UTC by Nate Straz
Modified: 2009-04-16 20:22 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0149
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-10 21:20:15 UTC


Attachments (Terms of Use)
fix (deleted)
2007-02-06 19:55 UTC, Lon Hohberger
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0149 normal SHIPPED_LIVE rgmanager bug fix update 2007-05-10 21:16:41 UTC

Description Nate Straz 2007-02-06 15:16:30 UTC
rgmanager-1.9.57-1 is also affected by this bug.


+++ This bug was initially created as a clone of Bug #222961 +++

Description of problem:

clustat -x doesn't have group information filled in.  Without the -x flag, group
information is displayed.

Version-Release number of selected component (if applicable):
rgmanager-2.0.21-1

How reproducible:
100%

Steps to Reproduce:
1. start an rgmanager service
2. clustat -x
3.
  
Actual results:
$ qarsh root@tank-04 clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  tank-02                               2 Online, rgmanager
  tank-03                               3 Online, rgmanager
  tank-04                               4 Online, Local, rgmanager
  tank-05                               5 Online, rgmanager

  Service Name         Owner (Last)                   State         
  ------- ----         ----- ------                   -----         
  service:nfs_service  tank-04                        started         
$ qarsh root@tank-04 clustat -x
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="1"/>
  <nodes>
    <node name="tank-02" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000002"/>
    <node name="tank-03" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000003"/>
    <node name="tank-04" state="1" local="1" estranged="0" rgmanager="1"
nodeid="0x00000004"/>
    <node name="tank-05" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000005"/>
  </nodes>
  <groups>
  </groups>
</clustat>


Expected results:


Additional info:

-- Additional comment from nstraz@redhat.com on 2007-01-16 22:56 EST --
clustat -x output is used by our testing tools to verify the state of rgmanager
services during tests.  

-- Additional comment from pm-rhel@redhat.com on 2007-01-16 23:00 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

-- Additional comment from pm-rhel@redhat.com on 2007-01-16 23:05 EST --
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

-- Additional comment from nstraz@redhat.com on 2007-01-16 23:17 EST --
Found rgmanager-2.0.17-4 to be in working order.
Found rgmanager-2.0.19-1 to be the first broken package.

Expected results:

[root@tank-04 ~]# clustat -x
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="1"/>
  <nodes>
    <node name="tank-02" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000002"/>
    <node name="tank-03" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000003"/>
    <node name="tank-04" state="1" local="1" estranged="0" rgmanager="1"
nodeid="0x00000004"/>
    <node name="tank-05" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0x00000005"/>
  </nodes>
  <groups>
    <group name="service:nfs_service" state="112" state_str="started" 
owner="tank-04" last_owner="none" restarts="0" last_transition="1168963028"
last_transition_str="Tue Jan 16 09:57:08 2007"/>
  </groups>
</clustat>


-- Additional comment from kanderso@redhat.com on 2007-01-17 11:06 EST --
Devel ACK.

-- Additional comment from lhh@redhat.com on 2007-01-17 11:17 EST --
Created an attachment (id=145832)
fixes it

This is REQUIRED for Conga and system-config-cluster to work!

[root@war utils]# clustat
Member Status: Quorate

  Member Name			     ID   Status
  ------ ----			     ---- ------
  war.lab.boston.redhat.com		1 Online, Local, rgmanager
  pestilence.lab.boston.redhat.com	2 Offline
  famine.lab.boston.redhat.com		3 Online

  Service Name	       Owner (Last)		      State	    
  ------- ----	       ----- ------		      -----	    
  service:war-pref     war.lab.boston.redhat.com      started	      
  service:pest-pref    war.lab.boston.redhat.com      started	      
  service:basic        war.lab.boston.redhat.com      started	      
  service:dependsonbas war.lab.boston.redhat.com      started	      
  service:test04       war.lab.boston.redhat.com      started	      
  service:test05       war.lab.boston.redhat.com      started	      
  service:test06       war.lab.boston.redhat.com      started	      
  service:test07       war.lab.boston.redhat.com      started	      
  service:test10       war.lab.boston.redhat.com      started	      
  service:test12       (none)			      disabled	      
[root@war utils]# clustat -x
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="1"/>
  <nodes>
    <node name="war.lab.boston.redhat.com" state="1" local="1" estranged="0"
rgmanager="1" nodeid="0x00000001"/>
    <node name="pestilence.lab.boston.redhat.com" state="0" local="0"
estranged="0" rgmanager="0" nodeid="0x00000002"/>
    <node name="famine.lab.boston.redhat.com" state="1" local="0" estranged="0"
rgmanager="0" nodeid="0x00000003"/>
  </nodes>
  <groups>
    <group name="service:war-pref" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050596" last_transition_str="Wed Jan 17 11:16:36 2007"/>
    <group name="service:pest-pref" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050596" last_transition_str="Wed Jan 17 11:16:36 2007"/>
    <group name="service:basic" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050596" last_transition_str="Wed Jan 17 11:16:36 2007"/>
    <group name="service:dependsonbasic" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050597" last_transition_str="Wed Jan 17 11:16:37 2007"/>
    <group name="service:test04" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050596" last_transition_str="Wed Jan 17 11:16:36 2007"/>
    <group name="service:test05" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050596" last_transition_str="Wed Jan 17 11:16:36 2007"/>
    <group name="service:test06" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050597" last_transition_str="Wed Jan 17 11:16:37 2007"/>
    <group name="service:test07" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050597" last_transition_str="Wed Jan 17 11:16:37 2007"/>
    <group name="service:test10" state="112" state_str="started" 
owner="war.lab.boston.redhat.com" last_owner="none" restarts="0"
last_transition="1169050597" last_transition_str="Wed Jan 17 11:16:37 2007"/>
    <group name="service:test12" state="119" state_str="disabled"  owner="none"
last_owner="none" restarts="0" last_transition="0" last_transition_str="Wed Dec
31 19:00:00 1969"/>
  </groups>
</clustat>
[root@war utils]# clustat -s test12
  Service Name	       Owner (Last)		      State	    
  ------- ----	       ----- ------		      -----	    
  service:test12       (none)			      disabled	      
[root@war utils]# clustat -x -s test12
<?xml version="1.0"?>
<clustat version="4.1.1">
  <groups>
    <group name="service:test12" state="119" state_str="disabled"  owner="none"
last_owner="none" restarts="0" last_transition="0" last_transition_str="Wed Dec
31 19:00:00 1969"/>
  </groups>
</clustat>


-- Additional comment from lhh@redhat.com on 2007-01-17 11:22 EST --
Fixes in CVS / RHEL5 RHEL50 HEAD

-- Additional comment from nstraz@redhat.com on 2007-01-19 15:41 EST --
Verified with rgmanager-2.0.23-1.

-- Additional comment from jturner@redhat.com on 2007-01-25 22:05 EST --
rgmanager-2.0.23-1 included in 20070124.1.

Comment 1 Lon Hohberger 2007-02-06 19:54:07 UTC
*** Bug 227547 has been marked as a duplicate of this bug. ***

Comment 2 Lon Hohberger 2007-02-06 19:55:34 UTC
Created attachment 147511 [details]
fix

Comment 3 Lon Hohberger 2007-02-06 19:56:22 UTC
fix in cvs

Comment 5 Red Hat Bugzilla 2007-05-10 21:20:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0149.html



Note You need to log in before you can comment on or make changes to this bug.