Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227472 - Message "sky2 eth0: phy read timeout" on console / in log
Summary: Message "sky2 eth0: phy read timeout" on console / in log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-06 07:29 UTC by Stephan Reiher
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-06 20:36:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephan Reiher 2007-02-06 07:29:24 UTC
Description of problem:
Message "sky2 eth0: phy read timeout" appears in /var/log/messages after loading driver sky2
and before "enabling interface"; also on shutdown, console is flooded with this message.

Second appearance: on standard installation from RHEL5 DVD (from iso image) after 
graphical installation screen has started, same message floods console #4.

Version-Release number of selected component (if applicable):
kernel: Linux version 2.6.18-1.2747.el5 (brewbuilder@hs20-bc2-3.build.redhat.com) (gcc version 
4.1.1 20061011 (Red Hat 4.1.1-30)) #1 SMP Thu Nov 9 18:55:30 EST 2006
kernel: sky2 v1.5 addr 0xf0100000 irq 169 Yukon-EC Ultra (0xb4) rev 2


How reproducible:
any time on boot/shutdown OR any time on installation

Steps to Reproduce:
1. Boot installed RHEL5 / Shutdown installed RHEL5 on notebook
2.
3.
  
Actual results:
message "sky2 eth0: phy read timeout" appears in log/messages or floods console

Expected results:
no such message

Additional info:
Hardware: Fujitsu Siemens Lifebook E8210 (ATI)
(Marvell 88E8055 PCI-E Gigabit Eth controller Rev 12)

On http://jmaurer.awardspace.info/e8210/ (Linux from Scratch on the same hardware) 
J.Maurer describes the same error and provides a bugfix: http://jmaurer.awardspace.info/e8210/
sky2.diff

Comment 1 Ernie Petrides 2007-09-05 21:19:07 UTC
Hello, Stephan.  Does this problem still exist with the RHEL5.1 beta kernel?

I ask because the latest kernel already contains the bug fix cited above,
although I don't know which RHEL5 kernel version first incorporated the fix.

Comment 2 Stephan Reiher 2007-09-06 13:11:59 UTC
Hello Ernie,

it existed in the Beta before the initial release of RHEL5, but _not_ in the current released 
version (with kernel 2.6.18-8.1.8.el5); i'm not using the Beta of RHEL5.1, so i cannot tell you.
And, for this issue, i was not sure, if a fix in the released RHEL should/would close a 
bug message in the Beta area ...

Thanks for taking care
Stephan

Comment 3 Ernie Petrides 2007-09-06 19:26:54 UTC
Thanks, Stephan.

Don, I couldn't find the patch tracking file associated with this fix,
so I'm just setting this to CLOSED/CURRENTRELEASE (5.0).  Feel free to
change the disposition (especially if you can find a dup).


Comment 4 Don Zickus 2007-09-06 20:31:23 UTC
I believe this have been fixed for 5.1.  Re-opening and moving to MODIFIED.

Comment 5 Don Zickus 2007-09-06 20:36:56 UTC
Nevermind, re-read comment #2.  Closing again.


Note You need to log in before you can comment on or make changes to this bug.