Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227463 - 2.6.18-1.2257.fc5xenU fails to boot
Summary: 2.6.18-1.2257.fc5xenU fails to boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: 5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-06 04:48 UTC by Ben
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.6.20-1.2307.fc5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 10:40:47 UTC


Attachments (Terms of Use)

Description Ben 2007-02-06 04:48:17 UTC
Description of problem:

2.6.18-1.2257.fc5xenU doesn't boot, presumably because of this message in the
boot log:

mount: could not find filesystem '/dev/root'


Version-Release number of selected component (if applicable):

Going to boot Fedora Core (2.6.18-1.2257.fc5xenU)
  kernel: /vmlinuz-2.6.18-1.2257.fc5xenU
  initrd: /initrd-2.6.18-1.2257.fc5xenU.img


How reproducible:

Always, on multiple domU machines.

Steps to Reproduce:
1. yum update to 2.6.18-1.2257.fc5xenU
2. boot domU
3. observe failure to create /dev/root
  
Actual results:

Some of the boot log:

Using config file "/etc/xen/cashnet".
Going to boot Fedora Core (2.6.18-1.2257.fc5xenU)
  kernel: /vmlinuz-2.6.18-1.2257.fc5xenU
  initrd: /initrd-2.6.18-1.2257.fc5xenU.img
Started domain cashnet
Bootdata ok (command line is  ro root=/dev/VolGroup00/LogVol00)
Linux version 2.6.18-1.2257.fc5xenU (brewbuilder@ls20-bc1-13.build.redhat.com)
(gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) #1 SMP Fri Dec 15 17:32:05 EST 2006
[snip]
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!



Additional info:

2.6.18-1.2239.fc5xenU was the last in a long line of kernels to have worked
fine. Fortunately, I can roll back to 2.6.18-1.2239.fc5xenU without apparent
issue, but I haven't tried to upgrade anything in my dom0 yet.

Comment 1 Ben 2007-03-07 05:14:51 UTC
FYI, this was fixed with 2.6.19-1.2288.2.4.fc5xenU.

Comment 2 Ben 2007-03-07 05:47:16 UTC
....and, just for clarity, 2.6.19-1.2288.fc5xenU does *not* work. What's up with
the "2.4" part of the rpm?



Comment 3 Ben 2007-03-07 16:55:15 UTC
Sorry, I have to take this back. While most hosts seem to work just fine with
2.6.19-1.2288.2.4.fc5xenU, I have a few that are still not able to mount /dev/root. 

Comment 5 Mark McLoughlin 2007-03-30 11:45:46 UTC
Is the latest kernel-xenU (2.6.20-1.2307.fc5) still broken ?

If so, what is the configuration of this domU? (i.e. /etc/xen/Foo)

Comment 6 Ben 2007-03-31 03:20:39 UTC
No, it seems 2.6.20-1.2307.fc5 fixes the problem. 

Comment 7 Mark McLoughlin 2007-04-02 10:40:47 UTC
Thanks Ben


Note You need to log in before you can comment on or make changes to this bug.