Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227459 - emacs muse info file not seen in dir
Summary: emacs muse info file not seen in dir
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-common-muse
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Underwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-06 02:54 UTC by Tom Tromey
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version: 3.02.93-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-10 12:24:34 UTC


Attachments (Terms of Use)

Description Tom Tromey 2007-02-06 02:54:16 UTC
The muse package installs the info file into /usr/share/info but
no 'dir' entry is installed.  This means that muse is not shown
in the top-level info page.

You can see this by starting emacs, typing C-h i, then searching
for 'muse'.

I think the problem is probably the %post script:

/sbin/install-info %{_infodir}/muse.info %{_infodir}/dir 2>/dev/null || :

... the file is called "muse", not "muse.info".  And as it is gzipped
perhaps it should be referred to as "muse.gz" here.

This also affects the %preun script.

I haven't tested my theory, so take with a grain of salt :)

Comment 1 Jonathan Underwood 2007-02-06 10:28:12 UTC
Aha - thanks for the report. I think your diagnosis is probably correct - will
fix and push new packages later.

Comment 2 Jonathan Underwood 2007-02-10 12:24:34 UTC
Fixed in new packages, closing bug - reopen if the problem persists.


Note You need to log in before you can comment on or make changes to this bug.