Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227455 - slapi_search_internal_get_entry returns incorrect error code
Summary: slapi_search_internal_get_entry returns incorrect error code
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 7.3
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 389_1.3.0
TreeView+ depends on / blocked
 
Reported: 2007-02-06 00:14 UTC by Bob Lord
Modified: 2017-03-09 16:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 16:52:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pete Rowley 2007-02-06 00:14:26 UTC
Description of problem:

If a plugin has failed to add its plugin id, instead using zero, the error code
returned is "no such object" when it should be "access denied" - it could also
be a bit more vocal in debug mode to alert the programmer that the failure is
due to plugin level authentication.  

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Martin Kosek 2012-01-04 13:47:16 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/134


Note You need to log in before you can comment on or make changes to this bug.