Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227439 - configure looks for libdbus in the wrong places for FC6
Summary: configure looks for libdbus in the wrong places for FC6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b
Version: 6
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 22:11 UTC by Jonathan Ryshpan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-09 15:29:11 UTC


Attachments (Terms of Use)

Description Jonathan Ryshpan 2007-02-05 22:11:48 UTC
Description of problem:
configure (as run by the source RPM distributed by Fedora) doesn't find
libdbus-1.so, which is (in fact) present on the system.  The problem is that
configure.in requests
   search_libs="$kde_libraries /usr/lib64 /usr/lib /usr/local/lib"
while libdbus-1.so is located in /lib and /lib64 on my system. 

Version-Release number of selected component (if applicable):
0.12.17 (using KDE KDE 3.5.5)

How reproducible:
Always

Steps to Reproduce:
Look at the log of 
  $ rpmbuild SPECS/k3b.spec

  
Actual results:
libdbus-1.so is not found

Expected results:
libdbus-1.so is found

Additional info:

Comment 1 Rex Dieter 2007-07-09 15:29:11 UTC
Not really applicable (in Fedora), since dbus-qt is what is *really* required
here, but can't, since it is in Extras, not Core.

Life is better with F7 (and beyond) since Core/Extras are merged.


Note You need to log in before you can comment on or make changes to this bug.