Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227406 (gecko-nopango) - garbage characters on some websites (pango disabled)
Summary: garbage characters on some websites (pango disabled)
Keywords:
Status: CLOSED RAWHIDE
Alias: gecko-nopango
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 227257 227475 227761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 20:40 UTC by Nikos Charonitakis
Modified: 2018-04-11 15:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-10 13:59:37 UTC


Attachments (Terms of Use)
screenshot example (deleted)
2007-02-05 20:41 UTC, Nikos Charonitakis
no flags Details
proposed patch (deleted)
2007-02-08 00:19 UTC, Akira TAGOH
no flags Details | Diff

Description Nikos Charonitakis 2007-02-05 20:40:20 UTC
Description of problem:
I used to browse without pango enabled. Everything was ok until few days ago
(probably after a firefox update) that some sites shows text as scattered
letters all over the text place. Firefox works ok
I have to enable pango to solve the problem (menu->system tools->system settings)
example sites:
http://oneiros.gr/blog/2007/02/04/etbloginlay
http://avi.alkalay.net/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nikos Charonitakis 2007-02-05 20:41:58 UTC
Created attachment 147398 [details]
screenshot example

Comment 2 Matěj Cepl 2007-02-05 23:23:08 UTC
Probably related to Firefox bug 227257. The solution is that you just should not
disable Pango -- running gecko without pango is not supported in Fedora (it is
there just for debugging/development reasons). See for more details the
mentioned bug.

Comment 3 Matěj Cepl 2007-02-05 23:24:55 UTC
sorry the braces in the previous comment should read
(the ability to switch off Pango stays in gecko just for ...)

Comment 4 Nikos Charonitakis 2007-02-06 00:02:37 UTC
(In reply to comment #2)
> Probably related to Firefox bug 227257. The solution is that you just should not
> disable Pango -- running gecko without pango is not supported in Fedora (it is
> there just for debugging/development reasons). See for more details the
> mentioned bug.

ok i have done that (disable pango) but this turns epiphany pretty useless.
Performance is so bad that you have to simply change browser to firefox.
Dont tell me switch to firefox :)




Comment 5 Matěj Cepl 2007-02-06 15:54:45 UTC
I am using epiphany myself :-), so I would tell you to file a bug against it and
describe thoroughly your problems with its performance.

Comment 6 Simos Xenitellis 2007-02-07 02:16:01 UTC
The effect of the screenshot shows that something has gone terribly wrong.
The course of action would be to save the offending page, chop it in small
pieces so that a simple small test case can be extracted.

We now test only with Pango as enabled. There is no going back.
Make sure that "MOZ_DISABLE_PANGO" is not set.

Comment 7 Christopher Aillon 2007-02-07 03:15:34 UTC
Behdad/Akira, any chances you might know what may have caused this?

Comment 8 Christopher Aillon 2007-02-07 03:17:36 UTC
*** Bug 227475 has been marked as a duplicate of this bug. ***

Comment 9 Behdad Esfahbod 2007-02-07 05:48:46 UTC
What was pushed to FC6?  Some of Akira's patches may be causing this.  Akira,
can you check?

Comment 10 Akira TAGOH 2007-02-07 09:28:26 UTC
Well, there seems not implemented GetRangeWidth in nsFontMetricsXft.

Comment 11 Christopher Aillon 2007-02-07 13:47:40 UTC
Can we implement that?

Comment 12 Matěj Cepl 2007-02-07 14:10:10 UTC
*** Bug 227257 has been marked as a duplicate of this bug. ***

Comment 13 Akira TAGOH 2007-02-07 14:32:49 UTC
Yes, I'm trying

Comment 14 Matěj Cepl 2007-02-07 23:46:36 UTC
*** Bug 227761 has been marked as a duplicate of this bug. ***

Comment 15 Akira TAGOH 2007-02-08 00:19:43 UTC
Created attachment 147619 [details]
proposed patch

attached patch will fixes this issue.

Comment 16 Martin Stransky 2007-02-09 10:47:12 UTC
That patch works fine for me...

Comment 17 Martin Stransky 2007-09-10 13:59:37 UTC
fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.