Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227400 - rubygems always exits with LoadError
Summary: rubygems always exits with LoadError
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygems
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lutterkort
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 20:04 UTC by Dean Mander
Modified: 2013-04-30 23:40 UTC (History)
1 user (show)

Fixed In Version: 0.9.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 01:31:11 UTC


Attachments (Terms of Use)
one line patch (deleted)
2007-02-06 02:47 UTC, Akira TAGOH
no flags Details | Diff

Description Dean Mander 2007-02-05 20:04:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
I installed:
$ yum install ruby-docs ruby-sqlite ruby-devel rubygems ruby-activerecord ruby-mysql

then I ran (for installing the rails frameworks):
$ gem install rails

gives error:

/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- sources (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:6
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:12
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:111:in `manage_gems'
        from /usr/bin/gem:10


in fact, the error is generic: running just "gem" gives the same error.



Version-Release number of selected component (if applicable):
rubygems-0.9.1-1.fc6

How reproducible:
Always


Steps to Reproduce:
1. run the gems command
2.
3.

Actual Results:


Expected Results:


Additional info:
I have installed the same software and versions of gem on a i386 system; here no problems...

Comment 1 Akira TAGOH 2007-02-06 02:45:56 UTC
It looks like a multilib issue in rubygems. rubygems shouldn't refers
CONFIG['libdir'] to build the default path of gems for 64bit arch since it's a
noarch package.

Comment 2 Akira TAGOH 2007-02-06 02:47:33 UTC
Created attachment 147431 [details]
one line patch

Comment 3 Dean Mander 2007-02-06 18:56:19 UTC
The patch solves the problem.

Thanks for the superfast fix!



Comment 4 David Lutterkort 2007-02-28 01:30:22 UTC
Fixed with update to 0.9.2

If anybody's interested, I used a slight variation of Akira's patch:

--- rubygems-0.9.1/lib/rubygems.rb.orig 2007-02-12 15:36:46.000000000 -0800
+++ rubygems-0.9.1/lib/rubygems.rb      2007-02-12 15:43:35.000000000 -0800
@@ -457,7 +457,9 @@
       if defined? RUBY_FRAMEWORK_VERSION
         return File.join(File.dirname(Config::CONFIG["sitedir"]), "Gems")
       else
-        File.join(Config::CONFIG['libdir'], 'ruby', 'gems',
Config::CONFIG['ruby_version'])
+        gemdir =
File::expand_path(File::join(Config::CONFIG["sitedir"],"..","gems"))
+
+        File.join(gemdir, Config::CONFIG['ruby_version'])
       end
     end



Note You need to log in before you can comment on or make changes to this bug.