Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227383 - generated anaconda-ks.cfg does not contain all selected packages
Summary: generated anaconda-ks.cfg does not contain all selected packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
: 237700 247550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 19:15 UTC by Doug Chapman
Modified: 2007-11-30 22:07 UTC (History)
6 users (show)

Fixed In Version: RHBA-2007-0644
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:20:12 UTC


Attachments (Terms of Use)
anaconda-ks.cfg generated when using @Everything (deleted)
2007-09-05 12:27 UTC, Alexander Todorov
no flags Details
anaconda-ks.cfg generated from "Select all optional packages" (deleted)
2007-09-05 12:28 UTC, Alexander Todorov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0644 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2007-10-30 22:56:59 UTC

Internal Links: 280101

Description Doug Chapman 2007-02-05 19:15:17 UTC
Description of problem:
Appears this is just seen under TUI mode.

If I do a manual install and choose the "customize" checkbox for the packages
the packages I select there do not show up in the generated anaconda-ks.cfg.  It
does appear that the packages get installed however.  But this prevents using
the anaconda-ks.cfg to reproduce the same configuration.

This _might_ be related to BZ 226758.


Version-Release number of selected component (if applicable):
RHEL5-Server-20070126.0
anaconda-11.1.2.34-2

How reproducible:
100%

Steps to Reproduce:
1. do a text mode install
2. choose to customize the packages to be installed
3. select all boxes in the customize screen

  
Actual results:
the anaconda-ks.cfg contains the same set of packages as if you had not added
packages on the customize screen.


Expected results:


Additional info:

Comment 1 Chris Lumens 2007-02-06 19:57:17 UTC
Is it possible for you to test for this same behavior on Rawhide?  I committed
something late last week that makes anaconda do a better job of writing out the
%packages section so it's possible fixing this is a simple matter of porting a
patch.  In particular, if you could test F7 test 1 to see that it is broken in
the same way, and then test the latest Rawhide tree with an updates.img I can
supply to see if it's fixed.

If you can't do that, perhaps I can just port the patch to RHEL5 anaconda and
you can see if that fixes it up.  Thanks.

Comment 2 Doug Chapman 2007-02-06 21:50:48 UTC
Chris,

It appears that rawhide works just fine even without an updates.img.  This was
with anaconda-11.2.0.19-1.


Comment 3 Chris Lumens 2007-03-08 16:48:42 UTC
What installation method were you using?

Comment 4 James Laska 2007-03-09 14:52:05 UTC
1) perform a http (unified tree) installation
2) Select optional packages (dasher, epic, and aide)
3) packages are installed by anaconda

# rpm -q dasher epic aide
dasher-4.2.0-2.el5
epic-2.4-1
aide-0.12-7


4) However, /root/anaconda-ks.cfg does not contain the selected optional packages

%packages
@base
@base-x
@core
@dialup
@editors
@gnome-desktop
@printing
@text-internet


Comment 5 RHEL Product and Program Management 2007-04-04 14:03:49 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Chris Lumens 2007-04-10 20:26:40 UTC
Does booting with updates=http://people.redhat.com/clumens/235881.img fix things?

Comment 7 Chris Lumens 2007-04-30 18:01:10 UTC
ACKing, as I think I have this figured out even without reporter verification.

Comment 8 James Laska 2007-05-01 13:50:41 UTC
All looks good when testing against RHEL-5-Server using the updates image noted
above.

Comment 10 Chris Lumens 2007-07-10 16:41:57 UTC
*** Bug 247550 has been marked as a duplicate of this bug. ***

Comment 11 JB Segal 2007-07-10 17:57:38 UTC
247550 is not a precise dupe, if A) the Text-mode-ness is an actual variable (my
install's done with the gui) and B) my output was even less than described in
the original report or in update 4:

[root@suffolk rhn]# tail -4 /root/anaconda-ks.cfg 
#logvol /tmp --fstype ext3 --name=LogVol01 --vgname=VolGroup00 --size=5120

%packages
@system-tools
[root@suffolk rhn]# 

(or:
[root@revere yum]# tail -4 /root/anaconda-ks.cfg 
#logvol /var --fstype ext3 --name=LogVol03 --vgname=VolGroup00 --size=10240

%packages
@editors
[root@revere yum]# 

Comment 13 Chris Lumens 2007-08-23 20:15:34 UTC
*** Bug 237700 has been marked as a duplicate of this bug. ***

Comment 15 Milan Zázrivec 2007-09-04 15:52:50 UTC
Verified with RHEL5.1-Server-20070904.nightly

Comment 16 Alexander Todorov 2007-09-05 12:26:59 UTC
Using the following scenario still hits this issue:

ks.cfg containing
------------------
%packages
@Everything
------------------
or
------------------
%packages
*
------------------

produces anaconda-ks.cfg containing @core, @base and some other packages,
which doesn't recreate the same system. Number of installed packages is 2098.

Performing manual install and customizing the packages selection in GUI works as
expected (but a bit strange). Right clicking with the mouse and selecting "All
optional packages" for every group leads to 1456 installed packages (less than
@everything ?!?). The generated anaconda-ks.cfg file recreates the same system
when used for subsequent install.

All installs are with latest RHEL5.1-Server-20070905.nightly tree, not using
installation key (Server repo only).

Cris,
can you answer these questions:
1) Is using @Everything the same issue or I should file it separately?
2) Why there is a difference between @Everything and "All optional packages"?



Comment 17 Alexander Todorov 2007-09-05 12:27:47 UTC
Created attachment 187291 [details]
anaconda-ks.cfg generated when using @Everything

Comment 18 Alexander Todorov 2007-09-05 12:28:27 UTC
Created attachment 187311 [details]
anaconda-ks.cfg generated from "Select all optional packages"

Comment 19 Chris Lumens 2007-09-05 18:27:36 UTC
Reusing a kickstart file and seeing what sort of %packages section gets
generated is sort of an odd corner case.  In the normal case, we key off what is
selected in the UI to know which lines to write out in anaconda-ks.cfg.  In
kickstart cases, none of this UI stuff is involved so we are probably just not
handling things correctly.

I've committed code to rawhide that simply copies the input kickstart file's
%packages section into the output kickstart file.  That seems like the most
reasonable thing to do here.  Can we open a new bug against 5.2 for that case
and use this bug just for the original issue?  I can attach a patch to a new bug
and get that moving for the next release.

Comment 20 Alexander Todorov 2007-09-06 07:48:30 UTC
Kickstart use case reported as Bug #280101.
Moving back to VERIFIED as per comment #15

Comment 21 Chris Lumens 2007-09-06 13:26:31 UTC
Thanks.

Comment 23 errata-xmlrpc 2007-11-07 17:20:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html



Note You need to log in before you can comment on or make changes to this bug.