Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227369 - cupsd not reloading after logrotate -> logs go to backup file
Summary: cupsd not reloading after logrotate -> logs go to backup file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-05 17:13 UTC by Thomas Springer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.2.7-8.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 17:34:02 UTC


Attachments (Terms of Use)

Description Thomas Springer 2007-02-05 17:13:06 UTC
Description of problem:

When logrotate finishes, cupsd appends logs to <logfile>.1 and doesn't use newly 
created logfile until the service is restarted.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=215023
reveals why this is the case, so i guess my problem is already known.

The RPM-changelog mentions bug 215024, but i'am not allowed to access this 
information :-/

What is it that cupsd cant't get reloaded by logrotate?

Version-Release number of selected component (if applicable):
cups-1.2.7-1.7.fc6

How reproducible:
Not hard.

Steps to Reproduce:
1. rotate logs
2. ll -t /var/log/cups/


BTW, MaxLogSize=2000000000 is afaics not the upstream default and I would like to 
know why 2G should be a good idea.

Comment 1 Tim Waugh 2007-02-05 17:17:04 UTC
Okay, the solution to this is to get CUPS to rotate its own logs and leave
logrotate out of it altogether.

It's no good trying to get logrotate to reload CUPS because it'll restart any
long-running print jobs, possibly wasting hundreds of sheets of paper.

Comment 2 Thomas Springer 2007-02-05 17:35:18 UTC
(In reply to comment #1)
> Okay, the solution to this is to get CUPS to rotate its own logs and leave
> logrotate out of it altogether.
Sounds good.

Thanks for your immediate reply..do you have a comment on the MaxLogSize entry  in 
cupsd.conf, please?

Comment 3 Tim Waugh 2007-02-05 17:49:10 UTC
We'll drop the size down so that cups ends up rotating its own logs.  It was set
at 2Gb just to avoid LFS problems IIRC.

Comment 4 Tim Waugh 2007-02-13 17:34:02 UTC
Fixed in devel: 1.2.7-8.fc7.



Note You need to log in before you can comment on or make changes to this bug.