Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227364 - built-in testsuite does not work on 64bit arches
Summary: built-in testsuite does not work on 64bit arches
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postgresql
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tom Lane
QA Contact: Kevin Baker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 16:46 UTC by Radek Bíba
Modified: 2014-12-01 23:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:17:50 UTC


Attachments (Terms of Use)

Description Radek Bíba 2007-02-05 16:46:19 UTC
Description of problem:
The built-in testsuite does not work on s390x and x86_64. First of all,
/usr/share/doc/postgresql-7.4.13/README.rpm-dist suggests cd'ing to
/usr/lib/pgsql/test/regress, but postgresql-test uses /usr/lib64/... on
64bit arches. Secondly, if you go to /usr/lib64/pgsql/test/regress, pg_regress
fails anyway:

...
============== installing PL/pgSQL                    ==============
createlang: language installation failed: ERROR:  could not access file
"/usr/lib/pgsql/plpgsql": No such file or directory pg_regress: createlang
failed
...

Version-Release number of selected component (if applicable):
postgresql-7.4.16-1.RHEL4.1

How reproducible:
Always

Steps to Reproduce:
1. see above
  
Actual results:
see above

Expected results:
success

Additional info:
Just out of curiosity, I tried to hack pg_regress to use
pkglibdir='/usr/lib64/pgsql' but many tests failed. Then I tried to revert
this hack and simply create a symlink from /usr/lib64/pgsql to /usr/lib/psql
and everything was great. Not sure if this is correct, though.

Comment 1 Tom Lane 2007-02-05 17:16:48 UTC
Yeah, this works in PG 8.0 and up but nobody ever bothered to fix it in 7.4.
I suppose if we're going to ship the postgresql-test RPM then we ought to make
some effort to make it work out-of-the-box ...

Comment 2 RHEL Product and Program Management 2008-02-01 19:10:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 4 Jiri Pallich 2012-06-20 13:17:50 UTC
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.


Note You need to log in before you can comment on or make changes to this bug.