Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227363 - kazehakase crash with idle_expand_row assertion failure
Summary: kazehakase crash with idle_expand_row assertion failure
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gail
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 16:45 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-17 05:13:50 UTC


Attachments (Terms of Use)
patch against gail 1.10.1, send from kazehakase upstream (deleted)
2007-02-05 16:45 UTC, Mamoru TASAKA
no flags Details | Diff
backtrace of kazehakase 0.4.4.1 (deleted)
2007-02-05 16:48 UTC, Mamoru TASAKA
no flags Details
backtrace of kazehakase 0.4.4.1 (again) (deleted)
2007-02-05 16:54 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2007-02-05 16:45:40 UTC
Description of problem:
On FC-devel kazehakaze, which I maintain in Fedora Extras
crash 100% on a certain condition.

I asked kazehakase upstream and kazehakase upstream craimed
this is due to gail bug and sent me a patch against gail.


Version-Release number of selected component (if applicable):
gail-1.10.1-1.fc7
kazehakase-0.4.4.1-2.fc7


How reproducible:
100%

Steps to Reproduce:
(Note: I usually use Japanese locale)
1. yum install kazehakase, launch kazehakase by type "kazehakase"
2. Click "Edit->Preference", choose "Tab -> New tab"
3. Change "New Tab position" to another value
4. Click "OK"
  
Actual results:
kazehakase crash, backtrace says that gail aborted
(will attach below)

Comment 1 Mamoru TASAKA 2007-02-05 16:45:40 UTC
Created attachment 147369 [details]
patch against gail 1.10.1, send from kazehakase upstream

Comment 2 Mamoru TASAKA 2007-02-05 16:48:50 UTC
Created attachment 147370 [details]
backtrace of kazehakase 0.4.4.1

Backtrace of kazehakase 0.4.4.1

Comment 3 Mamoru TASAKA 2007-02-05 16:54:30 UTC
Created attachment 147372 [details]
backtrace of kazehakase 0.4.4.1 (again)

The garbage followed by backtrace removed...

Comment 4 Mamoru TASAKA 2007-02-06 10:56:12 UTC
Kazehakase upstream (Hiroyuki Ikezoe) reported this
bug to gnome bugzilla.

Comment 5 Mamoru TASAKA 2007-02-17 05:13:50 UTC
The patch is committed into upstream CVS.


Note You need to log in before you can comment on or make changes to this bug.