Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227356 - read only mount allowed in %pre/%post sections of kicjstart file
Summary: read only mount allowed in %pre/%post sections of kicjstart file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 16:21 UTC by Tom Kennedy
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 14:20:42 UTC


Attachments (Terms of Use)
This is the kickstart file. (deleted)
2007-02-06 17:25 UTC, Tom Kennedy
no flags Details

Description Tom Kennedy 2007-02-05 16:21:36 UTC
Description of problem:

I have mount commands that are attempting to mount read/write file systems
during the %pre and %post phases of Linux installation.  When the instaler gets 
to these commands, a message saying the "the File system is Read Only" is 
printed.  I tried tp mount it manyally with the -rw options to mount, but it 
did not work.  The same commands work fine froma a RHEL4 installation, so I 
know the NFS mountse are OK.  

Version-Release number of selected component (if applicable):


How reproducible:

1) Add a mount command that mounts an NFS share read/write in the %pre or %post
sections of a kickstart file
   Add a command that echo text to a file on the mounted share
2) Start the installation

  
Actual results:

A message saying the mounted file system is Readonly is displayed

Expected results:

The file should be created with the echoed text.

Additional info:

Comment 1 Tom Kennedy 2007-02-05 23:02:02 UTC
The title is a little misleading.   It should say  write to NFS shared not 
allowwed in %pre/%post kickstart sections.

Comment 2 Chris Lumens 2007-02-06 15:47:42 UTC
What does your kickstart file look like?

Comment 3 Tom Kennedy 2007-02-06 17:25:41 UTC
Created attachment 147494 [details]
This is the kickstart file.

Comment 4 Tom Kennedy 2007-02-16 17:08:16 UTC
Solved.  Turns out one of the mounts did not have the -o nolock



Comment 5 Chris Lumens 2007-02-22 14:20:42 UTC
Closing as NOTABUG on the basis of comment #4.  If you still continue to see
problems even after adding -o nolock, please feel free to reopen this bug report.


Note You need to log in before you can comment on or make changes to this bug.