Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227339 - Failure to find file-based hard drive during para-virtualized install
Summary: Failure to find file-based hard drive during para-virtualized install
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 13:50 UTC by Chuck Hirstius
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 15:16:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chuck Hirstius 2007-02-05 13:50:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 1.1.4322)

Description of problem:
When trying to install a new para-virtualized guest on RHEL5b2 (attempted with RHEL5b2 and FC6) the installation is unable to detect a file-based hard drive to install onto forcing the installation to be terminated.

The machine I am testing on is an Intel P4 3.0Ghz (PAE Only), 1GB RAM, IDE based HD, and Intel chipset based video (82865G).

A sample command line of the install:

virt-install -n TestSrv01 -r 256 -f /var/vm/TestSrv01.img -s 5 --vnc -l nfs:x.x.x.x:/redhat/es50_b2

I have also noticed that the file configuration is always entered into the /xen/etc/TestSrv01 file is 'tap:aio' vs. 'file'.  FC6 on the same machine works with RHEL5b2 as a guest but the configuration entry always shows as 'file'.  Switching it to 'tap:aio' under FC6 also causes a failure to recognize the drive.

Version-Release number of selected component (if applicable):
xen-3.0.3-8.el5

How reproducible:
Always


Steps to Reproduce:
1. Install RedHat ES 5.0 beta 2 w/ Virtualization
2. Begin a para-virtualized guest OS installation of RHEL5b2 with a command line such as this:  virt-install -n TestSrv01 -r 256 -f /var/vm/TestSrv01.img -s 5 --vnc -l nfs:x.x.x.x:/redhat/es50_b2 (replacing x.x.x.x with a valid IP or host name)


Actual Results:
The OS install begins and runs normally until you get to the drive partitioning and layout section of anaconda.  At this point no available system drives will be found and installation cannot continue.

Expected Results:
The file-based drive created by the '-f' and '-s' arguments in the command line should have been visible to the installer.

Additional info:

Comment 1 Daniel Berrange 2007-02-05 13:54:30 UTC
Is SELinux turned on, and do you have any AVC denial messages in
/var/log/messages or /var/log/audit/audit.log ?

The SELinux policy only allows file backed domains to be kept under /xen
(legacy) or /var/lib/xen/images (recommended), so I would expect denials from
keeping them under /var/vm

Comment 2 Chuck Hirstius 2007-02-05 15:03:06 UTC
SELinux is enforcing, and yes, looking now at messages and the audit log I do 
see xen being denied r/w access to the .img file when it is placed 
under /var/vm.  I also verifed that the drive is indeed recognized 
when /var/lib/xen/images is selected as the intended .img file location.

Apparently the bug was in my head, not the OS.  Is this (default?) restriction 
documented anywhere?

Comment 3 Daniel Berrange 2007-02-05 15:16:54 UTC
The RHEL-5  Virtualization manual documents it. The current pre-release of the
manual is here.

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Virtualization-en-US/ch-virt-important-dirs.html

The final release of the docs for RHEL-5  GA will document the required
directories for SELinux much more clearly.



Note You need to log in before you can comment on or make changes to this bug.