Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227338 - Floating point ops failing on ia64 and stopping a service
Summary: Floating point ops failing on ia64 and stopping a service
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ntp
Version: 4.0
Hardware: ia64
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 13:26 UTC by jlcruz@ravenpack.com
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 13:37:19 UTC


Attachments (Terms of Use)

Description jlcruz@ravenpack.com 2007-02-05 13:26:28 UTC
Description of problem:

ntpd throwing errors to the /var/log/messages and not synchornizing to ntp
server. The errors were related to floating point errors when software assits
were needed.

Version-Release number of selected component (if applicable):
[root@research2 log]# uname -a
Linux research2.ravenpack.com 2.6.9-42.0.3.EL #1 SMP Mon Sep 25 17:14:34 EDT
2006 ia64 ia64 ia64 GNU/Linux
[root@research2 log]# rpm -q ntp
ntp-4.2.0.a.20040617-4.EL4.1


How reproducible:
Not reproducible. Restarting the service seemed to fix the problem. At least by
now, seems stable.

Aditional info:
Logs and info when the problem ocurred
[root@research2 log]# tail -f messages
Jan 26 19:39:38 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b12, isr 0000020000007001
Jan 26 19:39:38 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b32, isr 0000040000000008
Jan 26 19:39:38 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b41, isr 0000020000000008
Jan 26 19:39:38 research2 kernel: ntpd(3117): floating-point assist fault at ip
20000008001eb701, isr 0000020000000008
Jan 26 19:39:54 research2 ntpd[3117]: sendto(192.168.1.47): Invalid argument
Jan 26 19:40:42 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b12, isr 0000020000007001
Jan 26 19:40:42 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b32, isr 0000040000000008
Jan 26 19:40:42 research2 kernel: ntpd(3117): floating-point assist fault at ip
2000000800047b41, isr 0000020000000008
Jan 26 19:40:42 research2 kernel: ntpd(3117): floating-point assist fault at ip
20000008001eb701, isr 0000020000000008 


and the ntp was not in sync:
[root@research2 ~]# ntpq -p
     remote refid st t when poll reach delay offset jitter
==============================================================================
*LOCAL(0) LOCAL(0) 10 l 64 64 377 0.000 0.000 0.001
 ar47-01.researc .INIT. 16 u 44d 1024 0 0.000 0.000 4000.00 

after restarting the service, everything went back to normal state:
[root@research2 log]# ntpq -p
     remote refid st t when poll reach delay offset jitter
==============================================================================
 LOCAL(0) LOCAL(0) 10 l 54 64 377 0.000 0.000 0.001
*ar47-01.researc 213.194.159.3 3 u 53 64 377 0.398 -1750.2 0.829

Comment 1 Miroslav Lichvar 2007-02-05 13:37:19 UTC

*** This bug has been marked as a duplicate of 147980 ***


Note You need to log in before you can comment on or make changes to this bug.