Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227326 - deltarpm dumprpmheader corrupts rpm database
Summary: deltarpm dumprpmheader corrupts rpm database
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: deltarpm
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 10:01 UTC by Marcel Hild
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 15:16:36 UTC


Attachments (Terms of Use)
rpmdump header patch (deleted)
2007-02-05 10:01 UTC, Marcel Hild
no flags Details | Diff

Description Marcel Hild 2007-02-05 10:01:09 UTC
Description of problem:

deltarpm destroys the rpmDB when generating a RPM out of a deltarpm and the
installed RPM. This is due to an error in rpmdumpheader, which does not close
the RPM DB correctly.

How reproducible:
always

Steps to Reproduce:
1. /usr/bin/rpmdumpheader kpartx-0.4.7-8.el5 > /dev/null 
2. rpm -Uvh any_rpm.rpm will stall
  

This is already known by Michael Schröder, the upstream maintainer. And he will
incorporate the patch into his version.
In the meanwhile, we should patch our version.
Patch attached

Comment 1 Marcel Hild 2007-02-05 10:01:10 UTC
Created attachment 147345 [details]
rpmdump header patch

Comment 2 Michael Schwendt 2007-02-05 11:17:20 UTC
Reassigning. [Why is owners.list not propagated into bugzilla?]


Comment 3 Adam Jackson 2007-02-05 15:16:36 UTC
Fixed in deltarpm 3.3-6 in both FC6 and devel.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.