Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227317 - audacity is built with libresample rather than libsamplerate
Summary: audacity is built with libresample rather than libsamplerate
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 229135 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-05 06:30 UTC by Jonathan Ryshpan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-18 21:10:55 UTC
wtogami: fedora-cvs+


Attachments (Terms of Use)
Patch with comments. (deleted)
2007-02-05 06:30 UTC, Jonathan Ryshpan
no flags Details

Description Jonathan Ryshpan 2007-02-05 06:30:15 UTC
Description of problem:
As in summary.


Version-Release number of selected component (if applicable):
audacity-1.3.2-3.fc6 (as built on my machine from source)


How reproducible:
Always.


Steps to Reproduce:
1. $ ldd `which audacity` | less

Actual results:
   shows libresample (among other libs)

Expected results:
   should show libsamplerate (among other libs)


Additional info:

Comment 1 Jonathan Ryshpan 2007-02-05 06:30:15 UTC
Created attachment 147342 [details]
Patch with comments.

Comment 2 Gérard Milmeister 2007-02-05 21:06:43 UTC
Thanks.
I made a new build with fix.

Comment 4 Michael Schwendt 2007-02-18 20:52:35 UTC
*** Bug 229135 has been marked as a duplicate of this bug. ***

Comment 5 Michael Schwendt 2007-02-18 21:43:34 UTC
To expand on my comment in the Audacity bugzilla, when using
"--without-libresample --with-libsamplerate=system", the code builds
completely without resampling and only links libsamplerate. The result
is the terribly damaged audio output described in bug 229135.

Comment 6 Michael Schwendt 2007-02-24 01:05:04 UTC
Requesting co-maintainership access for "audacity" as suggested on
fedora-maintainer list:  bugs.michael@gmx.net



Note You need to log in before you can comment on or make changes to this bug.