Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227288 - highly reproducable crash when reading mail
Summary: highly reproducable crash when reading mail
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-04 20:37 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 21:51:09 UTC


Attachments (Terms of Use)
backtrace of crash (deleted)
2007-02-04 20:37 UTC, David Nielsen
no flags Details
Another backtrace of evolution crashing (deleted)
2007-02-06 16:57 UTC, David Nielsen
no flags Details
Yay.. another backtrace (deleted)
2007-02-06 19:26 UTC, David Nielsen
no flags Details

Description David Nielsen 2007-02-04 20:37:46 UTC
Description of problem:
I get a very reproducable crash when reading mail, I'm unsure what the trigger
is but it happens 10-20 times a day here. I've attached the backtrace in the
hope it helps.

Version-Release number of selected component (if applicable):
evolution-2.9.5-4.fc7
evolution-data-server-1.9.5-3.fc7
libgnome-2.17.90-1.fc7
libgnomeui-2.17.90-1.fc7
atk-1.13.2-1.fc7
gtk2-2.10.9-3.fc7
glib2-2.12.9-1.fc7
glibc-2.5.90-16

How reproducible:
100%

Comment 1 David Nielsen 2007-02-04 20:37:46 UTC
Created attachment 147329 [details]
backtrace of crash

Comment 2 Matthew Barnes 2007-02-04 20:48:22 UTC
Thanks for the bug report.  I've seen several crash reports like this where
accessibility libraries seem to be the cause of the crash.  Turning off
accessibility seems to make Evolution more stable for some users.

Can I ask you to install atk-debuginfo and post another backtrace the next time
you see this crash?

Comment 3 David Nielsen 2007-02-04 21:13:03 UTC
atk-debuginfo is installed for that backtrace. Could some other debuginfo
package be missing?

Comment 4 David Nielsen 2007-02-06 16:57:54 UTC
Created attachment 147492 [details]
Another backtrace of evolution crashing

Comment 5 David Nielsen 2007-02-06 17:20:36 UTC
great, I noticed glibc-debuginfo was went missing and after installing it
Evolution picks that time to stop crashing after this happening about 10 times
in a row after some eager clicking - if absolutely strictly needed please have
patience as I force Evolution into submission.

Comment 6 David Nielsen 2007-02-06 19:26:17 UTC
Created attachment 147509 [details]
Yay.. another backtrace

Yep, the reign of stability ended, this time we have a proper trace of the a11y
crash.

Comment 7 Christopher Aillon 2007-04-17 19:43:47 UTC
Matt says this might have gotten fixed by alex's patch... Is this still an
issue?  If not we probably should try to get this for FC7.

Comment 8 David Nielsen 2007-04-17 21:51:09 UTC
Seems to have gone.. let's call this one fixed, thank you Alex


Note You need to log in before you can comment on or make changes to this bug.