Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227285 - Cannot modify security level configuration
Summary: Cannot modify security level configuration
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-securitylevel
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
: 238336 241980 242190 242363 242498 242614 247236 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-04 19:05 UTC by Michel Alexandre Salim
Modified: 2007-11-30 22:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-31 10:11:52 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2007-02-04 19:05:04 UTC
Description of problem:
system-config-securitylevel would silently fail to apply configuration changes.
I added ports 5100/tcp and 5100/udp to the list of opened port, and they are not
actually being opened. The next time I ran s-c-sl, the ports are no longer listed.

Worse, I disabled the firewall from s-c-sl, and it is indeed stopped, but the
next time I ran s-c-sl it claimed that the firewall is still up

Version-Release number of selected component (if applicable):
1.7.0-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Try adding a port to be opened
2. Try disabling firewall
3. Try reenabling firewall
  
Actual results:
1) fails silently. 2) works, but is not reflected in the interface. 3) fails --
/sbin/service iptables show firewall still down

Expected results:
As in FC6, everything should work


Additional info:
System cleanly installed from FC7t1 desktop spin, updated to latest Rawhide

Comment 1 Luke Macken 2007-02-08 04:05:56 UTC
I'm experiencing the same issue; manually added ports are disappearing after
applying the settings.

Comment 2 Peter Sabiniewicz 2007-02-26 21:28:52 UTC
I'm experiencing  the same issue in my FC6
Custom add port are disappearing after and apply settings.

Comment 3 Josep 2007-03-14 21:41:19 UTC
Just to add that, if enabled, the firewall can not be disabled either. (rawhide
here)


Comment 4 Michael 2007-04-03 14:18:20 UTC
still broken in F 6.92

Comment 5 vfiend 2007-06-01 06:06:58 UTC
Still broken in Fedora 7 final release

Comment 6 markm 2007-06-03 19:03:40 UTC
Still broken in Fedora 7 final release.

Comment 7 Thomas Woerner 2007-06-08 15:12:23 UTC
*** Bug 238336 has been marked as a duplicate of this bug. ***

Comment 8 Thomas Woerner 2007-06-08 15:13:24 UTC
*** Bug 241980 has been marked as a duplicate of this bug. ***

Comment 9 Thomas Woerner 2007-06-08 15:14:23 UTC
*** Bug 242190 has been marked as a duplicate of this bug. ***

Comment 10 Thomas Woerner 2007-06-08 15:15:12 UTC
*** Bug 242363 has been marked as a duplicate of this bug. ***

Comment 11 Thomas Woerner 2007-06-08 15:15:28 UTC
*** Bug 242498 has been marked as a duplicate of this bug. ***

Comment 12 Thomas Woerner 2007-06-08 15:16:08 UTC
*** Bug 242614 has been marked as a duplicate of this bug. ***

Comment 13 Scott Berry 2007-06-10 02:46:48 UTC
I have found this to be true when hitting the apply button on a Dell Dimension 
4600.  I tried opening port 10000, and 20000.

Comment 14 Jason Farrell 2007-06-10 02:53:58 UTC
appears to be fixed in system-config-securitylevel-1.7.0-3.fc7

Comment 15 vfiend 2007-06-10 03:01:47 UTC
Yup, thanks a lot, whoever fixed it!

Comment 16 Stefan Becker 2007-06-16 10:14:37 UTC
Confirmed. system-config-securitylevel-1.7.0-3.fc7 from updates-testing fixes
the problem.

Comment 17 Tim Hartley 2007-06-27 15:46:20 UTC
Thanks a lot for fixing this!  Is there anything regular users can do to get
this pushed into updates?  It seems like if the standard tool to change firewall
settings doesn't work, then even a not-completely-tested fix is better.

Comment 18 Ignacio Vazquez-Abrams 2007-07-06 07:56:09 UTC
*** Bug 247236 has been marked as a duplicate of this bug. ***

Comment 19 Jay Jaeger 2007-07-15 17:19:54 UTC
I had the same issue.  I also found a workaround:  click on any of the services
in the Trusted Services list pane -- it even works to click it twice to leave it
in the same state it had been in originally.

Comment 20 Thomas Woerner 2007-07-31 10:11:52 UTC
Fixed in rawhide in package system-config-securitylevel-1.7.0-4.fc8.

Comment 21 Granville Xiong 2007-08-02 05:09:43 UTC
Will this update be reflected in FC7 soon???


Note You need to log in before you can comment on or make changes to this bug.