Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227276 - Spell-checking and caret movements does not work with Pango disabled
Summary: Spell-checking and caret movements does not work with Pango disabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-04 17:16 UTC by Lars E. Pettersson
Modified: 2018-04-11 08:44 UTC (History)
2 users (show)

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-10 14:09:25 UTC


Attachments (Terms of Use)

Description Lars E. Pettersson 2007-02-04 17:16:10 UTC
Description of problem:

Spell-checking while typing a new message, and the placement of the caret, does
not work when Pango is disabled.

Version-Release number of selected component (if applicable):

thunderbird-1.5.0.9-7.fc6

How reproducible:

Everytime I un-comment the MOZ-DISABLE-lines in /usr/bin/thunderbird

Steps to Reproduce:
1. Uncomment the MOZ-DISABLE-lines in /usr/bin/thunderbird
2. Start thunderbird
3. Write a new mail
4. Do some typing errors, try to move the caret backwards, forwards
  
Actual results:

Typing errors are not highlighted though they should, and the caret does not
follow the movements of the left/right arrows.

Expected results:

Errors highlighted and a caret that follows the arrow keys.

Additional info:

Perhaps related with http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=227257

Comment 1 Feng Yu 2007-02-04 18:00:58 UTC
I also meet the caret problem on firefox-1.5.0.9-2.fc6 when pango is disabled.



Comment 2 Matěj Cepl 2007-02-05 14:07:17 UTC
Could fully reproduce with thunderbird-1.5.0.9-6 on RHEL 5?

Comment 3 Matěj Cepl 2007-02-05 15:10:40 UTC
(In reply to comment #2)
> Could fully reproduce with thunderbird-1.5.0.9-6 on RHEL 5?

s/?/./

Comment 4 Matěj Cepl 2007-02-05 23:20:21 UTC
probably related to this is a bug 227437?

Comment 5 Matěj Cepl 2007-12-10 09:23:23 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 6 Lars E. Pettersson 2007-12-10 09:42:53 UTC
This works with Fedora7. The bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.