Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227268 - autofs timeout/expiration of /misc/cd unreliable
Summary: autofs timeout/expiration of /misc/cd unreliable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ian Kent
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-04 15:13 UTC by Peter Åstrand
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.0.1-0.rc3.16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 07:46:39 UTC


Attachments (Terms of Use)
Fix race when setting task to status to done (deleted)
2007-02-05 03:01 UTC, Ian Kent
no flags Details | Diff

Description Peter Åstrand 2007-02-04 15:13:32 UTC
Description of problem:

I've activated a timeout of 3 seconds of /misc/cd by adding:

DEFAULT_TIMEOUT=3

...to /etc/sysconfig/autofs. All other autofs configuration files are untouched.
The problem is that the expiration/timeout only works sometimes. With kernel
2.6.19-1.2895.fc6, I could to "ls /misc/cd" a few times, with unmounting working
correctly, but after a few times, no more timeout/umount happens. With kernel
2.6.18-1.2798.fc6, the timeout doesn't work at all, it seems. 

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc3.10

How reproducible:
Configure autofs with DEFAULT_TIMEOUT=3 and restart it. Try "ls /misc/cd" a few
times and verify with "mount" that /misc/cd is still mounted even after many
seconds.

Comment 1 Ian Kent 2007-02-05 02:58:48 UTC
(In reply to comment #0)
> The problem is that the expiration/timeout only works sometimes. With kernel
> 2.6.19-1.2895.fc6, I could to "ls /misc/cd" a few times, with unmounting working
> correctly, but after a few times, no more timeout/umount happens. With kernel
> 2.6.18-1.2798.fc6, the timeout doesn't work at all, it seems. 

It seems there is a race when setting the expire task
status to completed.

Ian

Comment 2 Ian Kent 2007-02-05 03:01:38 UTC
Created attachment 147337 [details]
Fix race when setting task to status to done

Could you test this patch for me please.

Comment 3 Peter Åstrand 2007-02-05 07:56:46 UTC
This patch works great. Thanks!


Comment 4 Ian Kent 2007-02-05 10:20:04 UTC
(In reply to comment #3)
> This patch works great. Thanks!
> 

Good, I'll merge it.

Ian



Note You need to log in before you can comment on or make changes to this bug.