Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227260 - ISO-8859 manual pages mis-coded
Summary: ISO-8859 manual pages mis-coded
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-04 03:37 UTC by Nick Lamb
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-13 14:46:46 UTC


Attachments (Terms of Use)

Description Nick Lamb 2007-02-04 03:37:01 UTC
Description of problem:
During the transition to UTF-8 some manual pages have been damaged.

Version-Release number of selected component (if applicable): man-pages-2.39-5

How reproducible:

Steps to Reproduce:
1. Switch to an English locale (I used en_GB.UTF-8)
2. from a shell type e.g. exactly 'man iso_8859-15' (NB underscore and dash)
3. Examine the EURO SIGN
  
Actual results:

The obscure universal currency symbol ¤ is shown

Expected results:

The Euro currency symbol € should be shown

Additional info:

These manual pages were casualties of an otherwise mostly successful battle to
get rid of encoding problems in manual pages.

/usr/share/man/en/man7/iso_8859-2.7.gz
/usr/share/man/en/man7/iso_8859-7.7.gz
/usr/share/man/en/man7/iso_8859-9.7.gz
/usr/share/man/en/man7/iso_8859-15.7.gz
/usr/share/man/en/man7/iso_8859-16.7.gz

Each of these pages was converted to UTF-8 but with the assumption that their
original character set was ISO-8859-1 (or maybe Windows 1252). In fact they were
each in their respective native encoding. A tool like 'iconv' can fix this,
firstly undo the conversion to UTF-8, then redo it but choosing the correct
source encoding e.g.

iconv -f UTF-8 -t ISO-8859-1 < iso_8859-9.7 > tmpfile
iconv -t UTF-8 -f ISO-8859-9 < tmpfile > iso_8859-9.7

Meanwhile the ASCII versions of these pages of course don't do a very good job
of illustrating characters which explicitly aren't in ASCII. Since we can't
illustrate them properly we should just remove this column, there is a text
description of each character included so it's still useful as pure ASCII.

Comment 1 Ivana Varekova 2007-02-13 14:46:46 UTC
Fixed in man-peges-2.43-6.fc7 and man-pages-2_39-7_fc6.


Note You need to log in before you can comment on or make changes to this bug.