Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227239 - Multimedia Keypress Causes X Crash
Summary: Multimedia Keypress Causes X Crash
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-03 21:41 UTC by Matt Thompson
Modified: 2018-04-11 19:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-01 08:32:27 UTC


Attachments (Terms of Use)
Xorg.conf file (deleted)
2007-02-23 00:50 UTC, Matt Thompson
no flags Details
Xorg.0.log due to the crash (deleted)
2007-02-23 00:52 UTC, Matt Thompson
no flags Details
Xorg.0.log generated when I have no xorg.conf (deleted)
2007-02-23 00:57 UTC, Matt Thompson
no flags Details

Description Matt Thompson 2007-02-03 21:41:07 UTC
Description of problem:
Well, as the summary says, if I press any of the multimedia keys on my MS
Natural Keyboard Pro keyboard, it crashes X and dumps me
back to the ttys. (I start in Runlevel 3.)  This happens either in
Xfce4 or in Gnome, so I'm guessing it's X that is doing it.

The only two keys I've tried is the "Back" and "Mail" MM keys.  I was
trying to map their keycodes in xev, but bam.  It also crashes even
if xev is running, so I can't blame it.

Version-Release number of selected component (if applicable):
I think I have: xorg-x11-server-Xorg-1.1.1-47.5.fc6
I'm not too sure if that is the correct xorg rpm.

How reproducible: Always


Steps to Reproduce:
1. Start Xfce4 or Gnome
2. Press a multimedia key.
3. Crash.
  
Actual results:
X crashes dumping me back to the ttys.

Expected results:
A keycode is sent.  Not much more beyond that since
I can't map the keycodes until the keyboard stops
crashing X.

Additional info:
Here is the backtrace generated:


Backtrace:
0: X(xf86SigHandler+0x81) [0x80da1e1]
1: [0x628420]
2: X(ProcessOtherEvent+0x293) [0x8160023]
3: X(xf86eqProcessInputEvents+0x211) [0x80c9901]
4: X(ProcessInputEvents+0x29) [0x80db4f9]
5: X(Dispatch+0x7d) [0x8087fbd]
6: X(main+0x485) [0x806fa65]
7: /lib/libc.so.6(__libc_start_main+0xdc) [0x43e47f2c]
8: X(FontFileCompleteXLFD+0x1e9) [0x806eda1]

Fatal server error:
Caught signal 11.  Server aborting

Comment 1 Matěj Cepl 2007-02-06 00:07:31 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Matt Thompson 2007-02-23 00:50:44 UTC
Created attachment 148638 [details]
Xorg.conf file

Here is the xorg.conf file that might cause the problem.

Comment 3 Matt Thompson 2007-02-23 00:52:07 UTC
Created attachment 148639 [details]
Xorg.0.log due to the crash

Here is the Xorg.0.log file I get after a crash.

Comment 4 Matt Thompson 2007-02-23 00:57:39 UTC
Created attachment 148640 [details]
Xorg.0.log generated when I have no xorg.conf

Removing xorg.conf and starting x again does *not* cause a crash upon a
multimedia key press.

Comment 5 Matěj Cepl 2007-03-01 08:32:27 UTC
The explanation of your problem is really simple -- your original xorg.conf used
nvidia binary-only driver, which crashed. Of course, when RedHat's Xorg
autconfigures it never uses stuff like that, so now you are using open source nv
driver, which doesn't use all the functionality of your video adapter, but
apparently it works better. Standard text for nVidia binary-only driver users
follows:

Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).

Comment 6 Jan Martinek 2009-01-30 22:55:22 UTC
I confirm that the X server crashes when any multimedia key is pressed. I have USB keyboard Genius Slimstar. The crash is not caused by proprietary nvidia drivers because I have ATI RS690. I do not have any xorg.conf. This may be relevant:

xorg-x11-drv-ati-6.10.0-1.fc11.x86_64
xorg-x11-server-common-1.5.99.901-5.fc11.x86_64
kernel-2.6.28-0.113.rc7.git5.fc11.x86_64

I think this bugreport should be reopened.

Comment 7 Matěj Cepl 2009-01-31 20:25:05 UTC
(In reply to comment #6)
> I confirm that the X server crashes when any multimedia key is pressed. I have
> USB keyboard Genius Slimstar. The crash is not caused by proprietary nvidia
> drivers because I have ATI RS690. I do not have any xorg.conf. This may be
> relevant:
> 
> xorg-x11-drv-ati-6.10.0-1.fc11.x86_64
> xorg-x11-server-common-1.5.99.901-5.fc11.x86_64
> kernel-2.6.28-0.113.rc7.git5.fc11.x86_64

Go and file a new bug about that (or find the most approriate one among https://bugzilla.redhat.com/buglist.cgi?quicksearch=component%3Axorg-x11-drv-ati), but this bug is for nvidia driver, not ati.

Comment 8 Matěj Cepl 2009-01-31 20:25:31 UTC
sorry, in the last sentence you should read "chip" instead of "driver"


Note You need to log in before you can comment on or make changes to this bug.