Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227231 - libdwfl dwfl_module_addrname can't find symbol name for symbols with st_size=0.
Summary: libdwfl dwfl_module_addrname can't find symbol name for symbols with st_size=0.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: elfutils
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On: 227167
Blocks: 173278
TreeView+ depends on / blocked
 
Reported: 2007-02-03 19:41 UTC by Roland McGrath
Modified: 2009-04-15 10:13 UTC (History)
2 users (show)

Fixed In Version: 0.126
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-15 10:13:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Roland McGrath 2007-02-03 19:41:04 UTC
+++ This bug was initially created as a clone of Bug #227167 +++

Description of problem:
calling dwfl_module_addrname on a symbol with a st_size of 0 returns null when
it should return the symbol size.

Version-Release number of selected component (if applicable):
0.125

How reproducible:
always.

Steps to Reproduce:
1. Create assembly test with code for a function with no symbol size. That
segfaults.
2. Run the program and try to get a backtrace using dwfl_module_addrname.
  
Actual results:
Get null.

Expected results:
Get foo().

Additional info:
Check out the patch for a possible solution.

-- Additional comment from npremji@redhat.com on 2007-02-02 16:30 EST --
Created an attachment (id=147253)
Patch to implement finding addrname of functions with st_size=0.


-- Additional comment from npremji@redhat.com on 2007-02-02 16:32 EST --
Created an attachment (id=147254)
A program with a function foo with st_size = 0, that segfaults in foo.


-- Additional comment from roland@redhat.com on 2007-02-03 14:39 EST --
I've done a different fix.

Comment 2 RHEL Product and Program Management 2007-06-05 20:38:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 6 Roland McGrath 2009-04-15 10:13:58 UTC
This was fixed in 5.3 (-0.137-3.el5)


Note You need to log in before you can comment on or make changes to this bug.