Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227224 - [RFE] Package OpenOffice.org SDK
Summary: [RFE] Package OpenOffice.org SDK
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-03 18:39 UTC by Ville-Pekka Vainio
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.2.0-6.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-09 19:43:30 UTC


Attachments (Terms of Use)

Description Ville-Pekka Vainio 2007-02-03 18:39:31 UTC
Description of problem:
The OpenOffice.org SDK seems to be missing from Fedora's OpenOffice.org
packages. It is needed to make rpm packages that provide support for the Finnish
spellchecker and hyphenator Voikko http://voikko.sourceforge.net/

Experimental FC5 packages of Voikko have already been built in OpenSuse
BuildService http://software.opensuse.org/download/home:/fisu81/Fedora_Extras_5/
but the openoffice.org-voikko package couldn't be built because of this problem.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.4-5.5.10
openoffice.org-core-2.0.4-5.5.10
openoffice.org-langpack-fi_FI-2.0.4-5.5.10
openoffice.org-xsltfilter-2.0.4-5.5.10
openoffice.org-base-2.0.4-5.5.10
openoffice.org-math-2.0.4-5.5.10
openoffice.org-impress-2.0.4-5.5.10
openoffice.org-pyuno-2.0.4-5.5.10
openoffice.org-calc-2.0.4-5.5.10
openoffice.org-draw-2.0.4-5.5.10
openoffice.org-testtools-2.0.4-5.5.10
openoffice.org-graphicfilter-2.0.4-5.5.10

How reproducible:
Always.

Steps to Reproduce:
1. Install OpenOffice_org-voikko-1.2-7.1.src.rpm meant for OpenSuse 10.2 from
http://software.opensuse.org/download/home:/fisu81/openSUSE_10.2/src/
2. Try to build packages from the .spec file.
  
Actual results:
The build stops, because 
/usr/lib/openoffice.org2.0/sdk/setsdkenv_unix.sh can't be found.

Expected results:
The build should succeed, the directory /usr/lib/openoffice.org2.0/sdk/ with its
contents should be there.

Additional info:

Comment 1 Caolan McNamara 2007-02-09 19:43:30 UTC
I did a test build of the sdk, and successfully built your component against it.
So sdk will be in FC-7 (currently as rawhide) with forthcoming version
openoffice.org-sdk-2.2.0-6.3

Comment 2 Ville-Pekka Vainio 2007-02-09 20:30:19 UTC
Thanks.


Note You need to log in before you can comment on or make changes to this bug.