Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227173 - http-2.5.3.tm in the wrong directory
Summary: http-2.5.3.tm in the wrong directory
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 21:42 UTC by Wart
Modified: 2008-01-03 15:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-03 15:36:25 UTC


Attachments (Terms of Use)
install path fix (deleted)
2007-02-02 21:44 UTC, Wart
no flags Details | Diff

Description Wart 2007-02-02 21:42:49 UTC
Description of problem:
http module installed in wrong location

Version-Release number of selected component (if applicable):
tcl-8.5a5-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install tcl 8.5a5-6
2. Look in /usr/share/tcl8/8.5
  
Actual results:
http-2.5.3.tm is missing; It's found in /usr/share/tcl8/8.4 instead.

Expected results:
http-2.5.3.tm is found.

Additional info:

At one point in time this was giving me an error because the http 2.0 package
could not be found.  This doesn't seem to be a problem with this latest tcl
version, other than a cosmetic issue.

Comment 1 Wart 2007-02-02 21:44:07 UTC
Created attachment 147257 [details]
install path fix

This patch fixes the incorrect install directory in the Makefile.

Comment 2 Marcela Mašláňová 2007-11-13 12:20:56 UTC
Shouldn't be also this part in tcl8.5? I'm not sure if anything is needed in
tcl8.4 directory.

@echo "Installing package platform 1.0.3 as a Tcl Module";
@$(INSTALL_DATA) $(TOP_DIR)/library/platform/platform.tcl
$(SCRIPT_INSTALL_DIR)/../tcl8/8.4/platform-1.0.3.tm;
@echo "Installing package platform::shell 1.1.3 as a Tcl Module";
@$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl
$(SCRIPT_INSTALL_DIR)/../tcl8/8.4/platform/shell-1.1.3.tm;

Comment 3 Marcela Mašláňová 2007-12-21 12:02:21 UTC
I installed every *.tm into tcl8/8.5. Hope that works.

Version tcl-8.5.0


Note You need to log in before you can comment on or make changes to this bug.