Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227143 - Hock MCT0980 fails on Virt Limit = None
Summary: Hock MCT0980 fails on Virt Limit = None
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Product_Activation
Version: web230
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jon Freitag
QA Contact: Web Development
URL: http://www.webqa.redhat.com/wapps/hock
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 19:51 UTC by joseph canton
Modified: 2007-04-18 17:59 UTC (History)
0 users

Fixed In Version: web230
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 20:15:59 UTC


Attachments (Terms of Use)

Description joseph canton 2007-02-02 19:51:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.0.7-1.4.3 Firefox/1.0.7

Description of problem:
Regnum Service fails to properly proces Virt Limit = None.
Symptom is that Hock will show an error message on any RHEL5 sku
with Virt Limit = None, such as MCT0980.

Fix has been committed:
services-regnum-impl  FragmentVirtLimit.java rev 15791
                      EncodeRequest.java     rev 15790
                      VirtLimitsDictionaryServerImpl.java rev 15789

  



Version-Release number of selected component (if applicable):
Web230

How reproducible:
Always


Steps to Reproduce:
1.www.webqa.redhat.com/wapps/hock
2.chock with entitlement, and hock any Sku with Oracle Desc Element 'Virt Limit' with a value of 'None' , for example MCT0980.

3.

Actual Results:
Error msg on last page of Hock sequence

Expected Results:
hock of Rhel5 regnum.

Additional info:
failure is in regnum-service, sympton is in hock.
Fix commited as mentioned above.

Setting as high priority as it would be nice to hock all RHEl5 products.

Comment 1 Sudhir Mallamprabhakara 2007-02-05 18:17:00 UTC
Verified on Web_QA by hocking MCT0980.. but got a web-alert when tried to
activate the subscription number(09d9-f659-0844-4bf6) here is the webalert:

*Stack Trace:
org.springframework.webflow.engine.ActionExecutionException: Exception thrown
executing [AnnotatedAction@1c60acd targetAction =
com.redhat.www.activate.webflow.ValidateSubscriptionAction@8e9e3d, attributes =
map['method' -> 'bindAndValidate']] in state 'displayValidateSubscriptionForm'
of flow 'activate-flow' -- action execution attributes were 'map['method' ->
'bindAndValidate']'; nested exception is
com.redhat.services.common.exception.ServiceException: Service term could not be
parsed
Caused by: com.redhat.services.common.exception.ServiceException: Service term
could not be parsed
	at
com.redhat.services.product.model.Product.parseServiceTermInDays(Product.java:147)

Comment 2 Sudhir Mallamprabhakara 2007-02-05 18:17:54 UTC
Also the e-mail generated by hocking MCT0980 has the following text:

Dear Red Hat Customer,

Thank you for purchasing MCT0980 -      
${order.lineItems.get(0).productWrapper.prefWrapper.subscriptionDays}.

Comment 3 joseph canton 2007-02-05 19:20:01 UTC
web-alert problem rejected, this is another problem unrelated to this ticket.

e-mail problem:
${order.lineItems.get(0).productWrapper.prefWrapper.subscriptionDays}.

accepted.

Reassign to jfreitag to fix hock email problem.



Comment 4 Steve Milner 2007-02-05 19:30:23 UTC
Updated to ON_QA buy bugzillaupdater

Comment 5 joseph canton 2007-02-05 20:06:10 UTC
Hock message a result of WebQA database not being populated with Oracle Data.
Please sync oracle data and retest. Table web.erp_mtl_descr_element_values must
 be updated and current.
I have sent a problem to oracle-problems@redhat.com.


Comment 6 Mark Sechrest 2007-02-06 18:58:30 UTC
As this is a data issue, and for RHEL 5 at that, we're going to mark this
verified in 230. This should/will get retested in 231 with RHEL5.

Comment 7 Mark Sechrest 2007-02-27 20:15:59 UTC
Closing b/c 230 has been released


Note You need to log in before you can comment on or make changes to this bug.