Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227131 - Gnucash fails to load libraries and fails to start
Summary: Gnucash fails to load libraries and fails to start
Keywords:
Status: CLOSED DUPLICATE of bug 225116
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 18:34 UTC by Ralf Ertzinger
Modified: 2014-03-17 03:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-03 17:01:19 UTC


Attachments (Terms of Use)
gnucash startup strace (deleted)
2007-02-02 18:34 UTC, Ralf Ertzinger
no flags Details

Description Ralf Ertzinger 2007-02-02 18:34:17 UTC
Description of problem:
Starting gnucash results in a row of dlopen() failures and finally in the
failure to start.
A strace output is attached, grep for "gnome-search.la" to get to the
interesting part.
The strange thing about this is that gnucash says that it can not open the .la
files, but strace shows no trace of it actually trying to do so.
And all the .la files are just where they ought to be, and readable by the user
trying to run gnucash. no selinux.


Version-Release number of selected component (if applicable):
gnucash-2.0.4-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Try to start gnucash
2.
3.
  
Actual results:
Fails to start, stating missing .la files

Expected results:
Startup

Additional info:

Comment 1 Ralf Ertzinger 2007-02-02 18:34:18 UTC
Created attachment 147245 [details]
gnucash startup strace

Comment 2 Paul Dickson 2007-02-02 23:52:35 UTC
The very first error message I get is:

** (process:13315): WARNING **: Failed to dlopen()
'/usr/lib/gnucash/libgw-business-core.la': file not found

But a "rpm -qf" shows the file exists and belongs to gnucash-2.0.4-1.fc6.

Why the fc6?

Comment 3 Ralf Ertzinger 2007-02-03 11:31:12 UTC
gnucash has not been rebuilt for Fedora 7 so far, so the file is taken from the
FC6 tree.

Comment 4 Bill Nottingham 2007-02-03 17:01:19 UTC

*** This bug has been marked as a duplicate of 225116 ***


Note You need to log in before you can comment on or make changes to this bug.