Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227002 - Firefox/Evolution crash when printing under SELinux/strict/enforcing
Summary: Firefox/Evolution crash when printing under SELinux/strict/enforcing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 16:07 UTC by Ted Rule
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-22 14:13:02 UTC


Attachments (Terms of Use)

Description Ted Rule 2007-02-02 16:07:23 UTC
Description of problem:

Firefox-2 and Evolution crash when printing is invoked under strict SELinux
poliy [ It is presumed that Firefox-1.5 also crashes, and that the same
problem exists for targeted policy ]

The problem is that both Firefox and Evolution need access to /dev/random -
presumably so as to build a temporary print spool file name. Default policy
allows access to /dev/urandom, but not /dev/random.

A simple workround is to add

dev_read_rand($1_evolution_t) 

  and 

dev_read_rand($1_mozilla_t) 

to evolution.if and mozilla.if respectively.


Version-Release number of selected component (if applicable):

selinux-policy-strict-2.4.6-27


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Walsh 2007-02-05 20:28:18 UTC
Fixed in  selinux-policy-2.4.6-36

Comment 2 Daniel Walsh 2007-08-22 14:13:02 UTC
Fixed in current release


Note You need to log in before you can comment on or make changes to this bug.