Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 227 - Installer writes bad lilo.conf with multiple DOS partitions
Summary: Installer writes bad lilo.conf with multiple DOS partitions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-30 05:45 UTC by mvarso
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-30 16:03:40 UTC


Attachments (Terms of Use)

Description mvarso 1998-11-30 05:45:08 UTC
Note: Here I assume that the root.img and boot.img -files in
official RedHat ditribution (ie. CD-ROM) are identical with
those found in ftp.redhat.com. If that is not the case this
applies only to the files found in ftp site and its mirrors.

If there is already more than one DOS/Win partitions on the
disk(s), install program writes a section for all of them in
/etc/lilo.conf.
Problem is, that is gives all of them same label and lilo
refuses to understand that.
Result is that install program pops up an error in
"installing lilo" stage.
Install program continues othervice normally and quits
cleanly, but lilo will (of cource) not boot the system after
reset as expected.

Trivial solution is to use "custom boot" -disk and manually
clean up /etc/lilo.conf.
But I think it is not the first thing a newbie
wants/can do :)

It may well be that if DOS partitions are not marked as
"assessible" within install program, this bug won't appear.

I have heard at least two other people having same problem.
One of them had scsi disks and was upgrading from
RH5.1. Problem was still excactly the same.
(My system was normal pentium with two IDE disks)

Comment 1 Bill Nottingham 1998-11-30 16:03:59 UTC
*** This bug has been marked as a duplicate of 204 ***


Note You need to log in before you can comment on or make changes to this bug.