Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226982 - bind-sdb update nukes running ldap daemons
Summary: bind-sdb update nukes running ldap daemons
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
: 215997 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 13:49 UTC by Axel Thimm
Modified: 2013-04-30 23:35 UTC (History)
3 users (show)

Fixed In Version: 9.3.4-2.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 15:29:15 UTC


Attachments (Terms of Use)

Description Axel Thimm 2007-02-02 13:49:33 UTC
Description of problem:
bind-sdb injects dnszone.schema to openldap config which openldap hasn't
read-access to. It then (tries to) restart ldap which fails on that. Recovering
from that error is hard if ldap is your primary authentication mechanism and
dirct rmeote root access is prohibited. It also nukes master and slave ldap
servers alike, so mass updates can render a whole network segment defunct.

Version-Release number of selected component (if applicable):
9.3.4-1.fc6

How reproducible:
100%

Steps to Reproduce:
1.yum update
2.
3.
  
Actual results:
ldap stops working, Restarting ldap fails

Expected results:
ldap daemon should not be nuked

Additional info:
This seems to be very similar to bug #215997, but that bug is supposedly fixed
in this package (?????)

Comment 1 Adam Tkac 2007-02-05 15:29:15 UTC
Fixed in 9.3.4-2.fc6 series. Update will be avaliable very soon

Comment 2 Adam Tkac 2007-02-05 15:31:52 UTC
*** Bug 215997 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.