Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226961 - Totem crash if i have a .txt file in the folder of the selected file.
Summary: Totem crash if i have a .txt file in the folder of the selected file.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gstreamer-plugins-base
Version: 5.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Adam Jackson
QA Contact:
URL: http://fedoraproject.org/wiki/DocsPro...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 09:40 UTC by Bastien Nocera
Modified: 2008-09-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-01 15:37:11 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-02-02 09:40:52 UTC
+++ This bug was initially created as a clone of Bug #189643 +++

(I do not speak well English :)

I have Fedora Core 5 installed in my PC (totem is update):

if I have a text file (txt) in same folder of the average file and these have
the same name (for example, sound.mp3 and sound.txt), Totem Crashes.

I have lame (mp3 plugin) because i update the gstreamer 0.10 from
http://gstreamer.freedesktop.org/pkg/fedora/5/0.10/i386/.

Also I will report this bug in gstreamer.org.

-- Additional comment from johnthacker@gmail.com on 2006-04-23 12:10 EST --
I can confirm this.  I can also confirm that this happens when playing a
filename.ogg file if filename.txt also exists in the same directory.
It doesn't seem to happen if filename.extension exists for extensions other
than .txt

Well, I don't get a crash, I get a hang in both cases.

-- Additional comment from johnthacker@gmail.com on 2006-04-23 12:12 EST --
Also happens for .avi and any other extension, if filename.txt exists.

-- Additional comment from johnthacker@gmail.com on 2006-10-25 14:59 EST --
Fixed in upstream CVS of gstreamer-plugins-base (no release yet).  Changing
component to gstreamer-plugins-base.

-- Additional comment from bnocera@redhat.com on 2007-02-01 09:29 EST --
Was fixed in gstreamer-plugins-base 0.10.11.



Upstream patch:
http://webcvs.freedesktop.org/gstreamer/gst-plugins-base/gst/playback/gstplaybasebin.c?r1=1.127&r2=1.128

Comment 1 Bastien Nocera 2008-09-01 15:37:11 UTC
Fixed by the gstreamer updates in RHEL 5.3.


Note You need to log in before you can comment on or make changes to this bug.