Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226952 - X.org server crash when pressing any extended "Internet" keys
Summary: X.org server crash when pressing any extended "Internet" keys
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-02 08:31 UTC by Andrew Zabolotny
Modified: 2018-04-11 11:17 UTC (History)
3 users (show)

Fixed In Version: 1.3.0.0-9.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-15 20:01:03 UTC


Attachments (Terms of Use)
The X.org config file (deleted)
2007-02-02 08:31 UTC, Andrew Zabolotny
no flags Details
X.org log file with crash report at the end (deleted)
2007-02-02 08:33 UTC, Andrew Zabolotny
no flags Details

Description Andrew Zabolotny 2007-02-02 08:31:44 UTC
Description of problem:

The X11 server crashes when I press any of the extended keys on the Logitech
Cordless keyboard (Logitech Cordless Desktop MX, this one:
http://www.ixbt.com/peripheral/logitech/cd-mx/img1.jpg). Alas it's not my
computer so I don't know with which version this bug has been introduced, I was
told that X11 "sometimes crashes" and went to investigate.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.5.fc6

How reproducible:
Always

Steps to Reproduce:
1. Boot into FC6
2. Even on the GDM screen (works in GNOME too) press any of the extended
so-called "Internet" keys, or any of the so-called "Multimedia" keys.
  
Actual results:
X11 crashes

Expected results:
Shouldn't :)

Additional info:
I tried to switch the keyboard model to "pc105" - nothing changed, still crashes.

I'm attaching xorg.conf and the X11 log with the crash report at the end.

Comment 1 Andrew Zabolotny 2007-02-02 08:31:44 UTC
Created attachment 147195 [details]
The X.org config file

Comment 2 Andrew Zabolotny 2007-02-02 08:33:24 UTC
Created attachment 147196 [details]
X.org log file with crash report at the end

Comment 3 Chris Shoemaker 2007-03-14 23:36:10 UTC
For quick reference, the log in comment #2 contains:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80da1e1]
1: [0x258420]
2: /usr/bin/Xorg(ProcessOtherEvent+0x293) [0x8160023]
3: /usr/bin/Xorg(xf86eqProcessInputEvents+0x211) [0x80c9901]
4: /usr/bin/Xorg(ProcessInputEvents+0x29) [0x80db4f9]
5: /usr/bin/Xorg(Dispatch+0x7d) [0x8087fbd]
6: /usr/bin/Xorg(main+0x485) [0x806fa65]
7: /lib/libc.so.6(__libc_start_main+0xdc) [0x674f2c]
8: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x806eda1]


Comment 4 Matěj Cepl 2007-12-10 09:22:07 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 5 Andrew Zabolotny 2007-12-15 20:01:03 UTC
Fedora 7 and 8 do not have this problem anymore.
I will close the bug.


Note You need to log in before you can comment on or make changes to this bug.