Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226879 - RFE: consider *.cmo and *.cmx as binary
Summary: RFE: consider *.cmo and *.cmx as binary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 20:17 UTC by Jerry James
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.79-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-02 16:06:45 UTC


Attachments (Terms of Use)

Description Jerry James 2007-02-01 20:17:37 UTC
Description of problem:
When rpmlint checks a package with only .cmo (Ocaml object file) or .cmx (Ocaml
native object file) files in /usr/lib[64], it issues the
only-non-binary-in-usr-lib warning.  However, those files are binary.  Can
BinariesCheck.check() be modified to include them?

Version-Release number of selected component (if applicable):
rpmlint-0.78-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Build an Ocaml package that puts .cmo or .cmx files into /usr/lib[64], but no
.o or .so files.
2. Run rpmlint on the package
  
Actual results:
rpmlint complains that there are only nonbinary files in /usr/lib[64]

Expected results:
rpmlint should not complain, since those files are binary

Additional info:

Comment 1 Ville Skyttä 2007-02-01 20:41:09 UTC
Hello Jerry, do you have a test package somewhere that could be used to test this?

Also, I'm completely clueless wrt. Ocaml - are both *.cmo and *.cmx architecture
dependent files?  file(1) says:

Objective caml native object file (.cmx) (Version 010).
Objective caml object file (.cmo) (Version 006).

...so does that mean that *.cmx is arch dependent, *.cmo arch independent?

What we're interested in in that particular rpmlint check is whether there's
only arch-independent stuff in /usr/lib (the "binary" word in the warning
identifier is somewhat misleading - binary files can be arch independent too,
but changing it could break people's warning message filters... :P).

Comment 2 Ville Skyttä 2007-02-01 20:45:30 UTC
Hm, Google gave me this:
https://gforge.inria.fr/plugins/scmsvn/viewcvs.php/trunk/INSTALL?rev=9116&root=coq&view=auto

"The important fact is that some files are architecture dependent (.cmx, .o and
executable  files for instance) but others are not (.cmo and .vo)."

...so I suppose presence of *.cmo should not suppress the warning, *.cmx should.

Comment 3 Ville Skyttä 2007-02-01 22:02:33 UTC
Done upstream, will be in the next release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1308

Comment 4 Ville Skyttä 2007-02-02 16:06:45 UTC
Done in upcoming 0.79-1.


Note You need to log in before you can comment on or make changes to this bug.