Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226803 - Error: uw-imap-devel conflicts with libc-client-devel
Summary: Error: uw-imap-devel conflicts with libc-client-devel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: uw-imap
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-01 17:59 UTC by John Guthrie
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 14:42:08 UTC


Attachments (Terms of Use)

Description John Guthrie 2007-02-01 17:59:42 UTC
Description of problem:
When I tried to install uw-imap-devel, I found out that I already had a previous
version installed because I got the message in the summary.  It turns out that I
had the libc-client-devel package installed from FC5.  Shouldn't uw-imap-devel
in fc6 be obsoleting libc-client-devel from fc5?  Or is this due to an explicit
Conflicts: tag?

Version-Release number of selected component (if applicable):
2006e-2.fc6

How reproducible:
Every time.

Steps to Reproduce:
1.Instal FC5 with libc-client-devel
2.Upgrade to FC6
3.Type "yum install uw-imap-devel"
  
Actual results:
I get the error in the summary

Expected results:
I would expect the libc-client-devel to get upgraded to uw-imap-devel

Additional info:

Comment 1 John Guthrie 2007-02-14 01:06:22 UTC
These two packages contain essentially the same files.  (uw-imap-devel does not
have documentation but contains two additional include files.)  I do have have a
cvs account.  Would anyone mind if I went in and fixed this myself?  (Of course,
I don't know if I have the appropriate write access privileges for this package. ;-)

Comment 2 Robert Scheck 2007-02-14 09:10:35 UTC
John, please WHAT do you wan't to fix at two (nearly) identical packages 
providing the same stuff? Personally, I would wait for Rex as he is the package 
maintainer and your request is just a few days old.

Comment 3 Rex Dieter 2007-02-14 14:35:30 UTC
John, 

*** This bug has been marked as a duplicate of 222486 ***

Comment 4 Rex Dieter 2007-02-14 14:37:39 UTC
Oops, different.  Reopening.

Comment 5 Rex Dieter 2007-02-14 14:42:08 UTC
Yeah, as it is now libc-client-devel and uw-imap-devel pretty much
include/provide *exactly* the same thing, just different versions of it, hence
the existing explict Conflicts (not ideal, I admit)

As it is now, CANTFIX/WONTFIX is appropriate (without major work anyway, which
I'd argue simply isn't worth it).

For F7, these two items will be merged and co-maintained,
http://bugzilla.redhat.com/225993
and life will be good.


Note You need to log in before you can comment on or make changes to this bug.