Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226778 - Open Office doesn't select whole words
Summary: Open Office doesn't select whole words
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 15:48 UTC by B.M.
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-01 16:20:14 UTC


Attachments (Terms of Use)

Description B.M. 2007-02-01 15:48:26 UTC
Description of problem:
When trying to select words by left clicking the mouse, users have to start at
the beginning of the word, in order to get the whole word marked. They cannot
start for instance in the middle of the word, because then only these characters
get selected. 
BUT: Due to an unreproducible circumstance Oowriter somehow marked WHOLE words,
not just characters. As long as i didn't logout, i could leftclick the mouse,
start in the middle of a word, drag the mouse further to select words next to
it, and it automatically selected only whole words!
After relogin it ceased to work that way.
So this feature seems to be included, but doesn't work properly (only one single
time).

Version-Release number of selected component (if applicable): 2.0.4-5.5.10


How reproducible:

always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Oowriter should select whole words, not single characters


Additional info:

Comment 1 Caolan McNamara 2007-02-01 16:20:14 UTC
Use the keyboard and hold shift and then left/right cursor keys to select text
by word. Double clicking on a word with the mouse selects the word underneath
the mouse cursor.

You may have simply hit one of the items in the status bar, see
http://wiki.services.openoffice.org/wiki/FAQ:Writer#How_to_select_multiple_parts_of_the_text.3F

Comment 2 B.M. 2007-02-02 11:57:39 UTC
Excuse me, but it seems i have not described the bug plasticly enough: I know
that i can select whole words with keyboard. But it should be possible to select
whole words with mouse. Please refer to the MS-pendant. There only whole words
are being selected, because nobody ever wants to select a few characters out of
a word, and leave the rest of it where it stands. This doesn't make any sense at
all. I thought this feature was not implemented in Oowriter, but, as i described
above, it IS implemented, because it did work, if only for one single time - by
some miracle. 
Therefore it is a bug.

Comment 3 B.M. 2007-03-13 11:43:22 UTC
Sorry, my fault. The requested feature was already implemented. User has to
double click a word and hold the button pressed, then move to the next word. In
this mode OpenOffice selects only whole words, not just single characters.


Note You need to log in before you can comment on or make changes to this bug.