Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226746 - mount hang with mount nfs share
Summary: mount hang with mount nfs share
Keywords:
Status: CLOSED DUPLICATE of bug 228868
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 13:47 UTC by Alex Lyashkov
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-02 19:01:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix read fsid type3 in mountd. (deleted)
2007-02-01 18:11 UTC, Alex Lyashkov
no flags Details | Diff

Description Alex Lyashkov 2007-02-01 13:47:25 UTC
Description of problem:
when I tried to mount lustre FS exported via nfs - mount hang in data wait state.

Version-Release number of selected component (if applicable):
kernel 2.6.9-42.0.3
nfs-tools 1.0.6-70.el

How reproducible:
always.

Steps to Reproduce:
1. create device with major or minor number over 256 and export via nfs.
  
Actual results:
mount hand

Expected results:
mount ok.

Additional info:
bug exist in both kernel and nfs tools.

first bug in nfs-tools,
nfs-tools can`t be read fsid type 3 from kernel hash - nfsd.fh and grop request
without any error message. for fix this function nfsd_fh in utils/mount should
be updated from lastes version (i test with 1.0.10).
second bug exist in fs/nfsd/export.c - he also drop fsid type 3 from tools.
this fixed with small patch (get from 2.6.16 kernel)
--- export.c.orig       2007-02-01 14:46:17.000000000 +0200
+++ export.c    2007-02-01 14:46:34.000000000 +0200
@@ -132,7 +133,7 @@
        if (*ep)
                goto out;
        dprintk("found fsidtype %d\n", fsidtype);
-       if (fsidtype > 2)
+       if (key_len(fsidtype)==0) /* invalid type */
                goto out;
        if ((len=qword_get(&mesg, buf, PAGE_SIZE)) <= 0)
                goto out;

after this changed i`m able to export filesystems with fsid type 3.

Comment 1 Alex Lyashkov 2007-02-01 18:11:19 UTC
Created attachment 147125 [details]
fix read fsid type3 in mountd.

Comment 2 Alex Lyashkov 2007-02-26 17:26:06 UTC
hm... it this fix will be included in next RHEL4 update ?

Comment 3 RHEL Product and Program Management 2007-05-09 08:01:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Steve Dickson 2007-08-02 17:33:53 UTC
Fixed in nfs-utils-1.0.6-82.EL4

Comment 6 Jeff Layton 2007-08-02 19:01:02 UTC
The patch in comment #1 was committed as part of U5 for BZ 228868. It should be
in nfs-utils versions >= -78.EL. Closing this bug as a duplicate. Please reopen
if you're still having issues...


*** This bug has been marked as a duplicate of 228868 ***


Note You need to log in before you can comment on or make changes to this bug.