Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226742 - Random soft lockup when plugging/unplugging USB mass storage device
Summary: Random soft lockup when plugging/unplugging USB mass storage device
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2007-02-01 13:11 UTC by Julian Sikorski
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-09-13 20:58:05 UTC

Attachments (Terms of Use)
Appropriate part of /var/log/messages (deleted)
2007-02-21 23:06 UTC, Julian Sikorski
no flags Details
Yet another miraculously captured log (deleted)
2007-04-13 16:31 UTC, Julian Sikorski
no flags Details
Output of dmesg showing the soft lockup error message (deleted)
2007-05-24 08:52 UTC, Erkki Ruohtula
no flags Details

Description Julian Sikorski 2007-02-01 13:11:25 UTC
Description of problem:
I have started to encounter thin problem since I've upgraded to 2.6.19 kernel,
so I suspect it may be the cause. The problem is that the freeze is not
reproducible, it just happens from time to time. I have tried Nikon D70 camera
set in mass storage mode and Kingston Data Traveler 512 MB.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot the system
2. plug or unplug the usb device
Actual results:
system freezes

Expected results:
no freeze

Additional info:
I'd very happily submit additional information, just need directions how to do
so. Here are the last lines of /var/log/messages:

Feb  1 12:42:53 fclaptop kernel: usb 5-4: new high speed USB device using
ehci_hcd and address 4
Feb  1 12:42:53 fclaptop kernel: usb 5-4: configuration #1 chosen from 1 choice
Feb  1 12:42:54 fclaptop kernel: audit(1170333774.189:32): avc:  denied  { write
} for  pid=1913 comm="mount.ntfs-3g" name="fuse" dev=tmpfs ino=1613
tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=chr_file

Comment 1 Julian Sikorski 2007-02-01 13:29:42 UTC
I don't know if it's related, but the system freezes as well when going to
suspend-to-ram and also randomly without any particular reason. This definitely
was not happening with the previous kernel. Cheers.

Comment 2 Julian Sikorski 2007-02-20 17:23:41 UTC
Well, with the current kernel, the random freezes have somehow vanished but the
other two issues remain. After reading Keith Packard's blog entry, I suspect it
may be a kernel panic. Is there any way I could get to console/logs/whatever
AFTER the freeze to figure out what has really happened? Cheers.

Comment 3 Chuck Ebbert 2007-02-20 23:55:37 UTC
Try netconsole.  google for
   netconsole linux

Comment 4 Julian Sikorski 2007-02-21 11:23:48 UTC
I'll be plugging devices while not in X from this point on, so if it is a kernel
panic, I'll see it.

Comment 5 Pete Zaitcev 2007-02-21 19:39:14 UTC
I agree with Chuck, netconsole is more helpful for bugfixing, for several reasons.
1. I saw cases when X affected things.
2. You have to edit /etc/sysconfig/syslog and add "-c 8" to KLOGD_OPTIONS
   if you want to see everything.
3. If the box wedges well enough, you won't be able to scroll back and our
   tracebacks are getting pretty long.
4. It's better for me to have a text dump attached than a JPEG of console
   (although either is better than nothing).

Don't needinfo bugs, they fall off developer's lists if you it.

I think I better take this. USB storage is one of the more used and more
reliable parts of our USB stack, this is very peculiar...

Comment 6 Julian Sikorski 2007-02-21 20:25:48 UTC
I agree that it is strange, too bad that it is so non-reproducible. I'll
investigate the netconsole then.

Comment 7 Julian Sikorski 2007-02-21 20:33:18 UTC
Bummer, it needs another pc to output the log to. I don't have access to any
atm. I'll try other methods then.

Comment 8 Julian Sikorski 2007-02-21 23:06:32 UTC
Created attachment 148547 [details]
Appropriate part of /var/log/messages

I reproduced it with X active, and somehow managed to “melt” the system
using SysRq magic and setting the keyboard to XLATE mode. I have attached the
/var/log/messages output.

Comment 9 Pete Zaitcev 2007-03-01 05:58:46 UTC
Oh, this is good. This is substantial... although captured purely by a miracle.
Usually /var/log/messages is useless.

Mental note: this may be related to bug 230322 (please do not dup!).

Comment 10 Pete Zaitcev 2007-03-09 01:38:18 UTC
Julian, please try 2.6.19-1.2911.6.4.fc6. There's a small chance that what
you are seing is the improper IRQ migration.

Comment 11 Julian Sikorski 2007-03-09 11:00:56 UTC
Well, it really looks like the problem is solved. I'll close this bug now, but
due to general non-reproducibility, I'll reopen it should the lockup happen
again. Cheers.

Comment 12 Julian Sikorski 2007-04-13 16:28:43 UTC
Bummer. It still happens from time to time with 2.6.20-1.2933.fc6. I'll attach
the log soon (it's a wee different now).

Comment 13 Julian Sikorski 2007-04-13 16:31:06 UTC
Created attachment 152555 [details]
Yet another miraculously captured log

Comment 14 Erkki Ruohtula 2007-05-24 08:52:05 UTC
Created attachment 155322 [details]
Output of dmesg showing the soft lockup error message

Comment 15 Erkki Ruohtula 2007-05-24 08:55:01 UTC
Comment on attachment 155322 [details]
Output of dmesg showing the soft lockup error message

This was on a Dell Core 2 Duo machine running in 64-bit mode after upgrading
the kernel to 2.6.20-1.2948.fc6 . Seems references to my USB memory dongle
often cause this error.

Comment 16 Julian Sikorski 2007-09-13 20:56:04 UTC
Taking into consideration the randomness of a random soft lockup, I'm tempted to
say this was fixed, as I haven't experienced a lockup for quite a while. Should
we close this, Erkki?

Comment 17 Julian Sikorski 2007-09-13 20:58:05 UTC
Umm, Erkki is not CCed. I am closing the bug then.

Note You need to log in before you can comment on or make changes to this bug.