Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226730 - [ko_KR] page number displayed garbled characters
Summary: [ko_KR] page number displayed garbled characters
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gedit
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 09:25 UTC by Nicole Dai
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-07 02:52:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot for gedit (deleted)
2007-02-01 09:25 UTC, Nicole Dai
no flags Details
screenshot for gedit in gu_IN (deleted)
2007-02-12 08:30 UTC, Nicole Dai
no flags Details
Problem was solved. (deleted)
2007-02-13 07:07 UTC, Mayank Jain
no flags Details

Description Nicole Dai 2007-02-01 09:25:01 UTC
Description of problem:
In ko_KR env, the page number was displayed garbled characters when print
document. Pls refer to the attached screenshot for details.

Version-Release number of selected component (if applicable):
gedit-2.16.0-5.el5
RHEL5-Client-20070126.0

How reproducible:
Always

Steps to Reproduce:
1.Log in ko_KR system.
2.Launch gedit.
3.Copy and paste some text to gedit and print it.
4.Check the page number.
5.Print the same doc in LANG=en_US.UTF-8 gedit.
6.Check the page number.
  
Actual results:
page number displayed garbled characters in ko_KR env but ok in en_US env.

Expected results:


Additional info:

Comment 1 Nicole Dai 2007-02-01 09:25:01 UTC
Created attachment 147080 [details]
screenshot for gedit

Comment 2 Mayank Jain 2007-02-12 07:52:27 UTC
Hi Nicole,

Both Gedit & Evolution use libgnomeprintui for the printing. Hence, I think this
is a libgnomeprintui bug rather than gedit.

Further, this seems to be a duplicate of Bug 222974.

Closing as DUP. Please feel free to reopen it if you think otherwise.

*** This bug has been marked as a duplicate of 222974 ***

Comment 3 Nicole Dai 2007-02-12 08:30:21 UTC
Created attachment 147877 [details]
screenshot for gedit in gu_IN

Hi Mayank,
I found this bug only in ko_KR locale. Other locales I tested before have no
problem and I also found it works well in gu_IN (as I noticed Bug 222974 was
reported for gu_IN). Could you please double-check it? Thanks.

Comment 4 Mayank Jain 2007-02-13 07:05:52 UTC
Hmm, okay, everything apart, I just checked & found that this was no more a
problem in gedit.

Check the screenshot in next comment.

Comment 5 Mayank Jain 2007-02-13 07:07:14 UTC
Created attachment 147965 [details]
Problem was solved.

Comment 6 Mayank Jain 2007-02-13 07:21:15 UTC
Nicole, is this looking correct now?

Comment 7 Hu Zheng 2007-02-13 07:24:43 UTC
I dig it and fint it is gedit ko translation's bug.
See gedit/po/ko.po, line 1834
#: ../gedit/gedit-print.c:194
msgid "Page %N of %Q"
msgstr "%2%Q 중 %1$N쪽"

Fix the translation will be OK. This need to be done by a people who understand
Korean :)
This bug exist in FC6 and RHEL5, and we may need to report this to upstream too.

Comment 8 Hu Zheng 2007-02-13 08:15:50 UTC
The upstream version have already fixed this.

gedit-2.17.5
#: ../gedit/gedit-print.c:194
msgid "Page %N of %Q"
msgstr "전체 %Q쪽 중 %N쪽"

gtksourceprintjob only use %N and %Q as mark, so to revert their order, we
needn't write %1$Q %2$N, just %Q %N is OK.


Comment 9 Mayank Jain 2007-02-13 09:42:07 UTC
Ah... very true.
This is fixed in upstream, thats why my gedit-2.17.4-1.fc7 had it fixed.

Thanks Hu Zheng :)

Comment 10 Akira TAGOH 2007-09-07 02:52:08 UTC

*** This bug has been marked as a duplicate of 250212 ***


Note You need to log in before you can comment on or make changes to this bug.