Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226681 - Wrong package included with distribution
Summary: Wrong package included with distribution
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng
Version: 5.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Daniel Mach
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 22:08 UTC by George Toft
Modified: 2011-01-04 15:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-04 15:28:04 UTC


Attachments (Terms of Use)

Description George Toft 2007-01-31 22:08:24 UTC
Description of problem:
mysql-5.0.22-2.1.i386.rpm is included with x86_64 distro - it should have been
mysql-5.0.22-2.1.x86_64.rpm.  This causes library dependency errors when trying
to install PHP.


Version-Release number of selected component (if applicable):
RHEL5 public beta 2
mysql-5.0.22


How reproducible:
Always


Steps to Reproduce:
[root@rhel5xen1 php]# rpm -ivh mysql-5.0.22-2.1.i386.rpm
perl-DBI-1.52-1.fc6.x86_64.rpm
warning: mysql-5.0.22-2.1.i386.rpm: Header V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:perl-DBI               ########################################### [ 50%]
   2:mysql                  ########################################### [100%]
[root@rhel5xen1 php]# updatedb
[root@rhel5xen1 php]# locate libmysqlclient.so.15
/usr/lib/mysql/libmysqlclient.so.15
/usr/lib/mysql/libmysqlclient.so.15.0.0
[root@rhel5xen1 php]# rpm -ivh php-mysql-5.1.6-3.x86_64.rpm
php-pdo-5.1.6-3.x86_64.rpm
warning: php-mysql-5.1.6-3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
error: Failed dependencies:
        libmysqlclient.so.15()(64bit) is needed by php-mysql-5.1.6-3.x86_64
        libmysqlclient.so.15(libmysqlclient_15)(64bit) is needed by
php-mysql-5.1.6-3.x86_64
[root@rhel5xen1 php]#


  
Actual results:
See above


Expected results:
[root@rhel5xen1 php]# rpm -ivh mysql-5.0.22-2.1.x86_64.rpm
warning: mysql-5.0.22-2.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID
4f2a6fd2
Preparing...                ########################################### [100%]
   1:mysql                  ########################################### [100%]
[root@rhel5xen1 php]# rpm -ivh php-mysql-5.1.6-3.x86_64.rpm
php-pdo-5.1.6-3.x86_64.rpm
warning: php-mysql-5.1.6-3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
Preparing...                ########################################### [100%]
   1:php-pdo                ########################################### [ 50%]
   2:php-mysql              ########################################### [100%]


Additional info:
The above expected results were obtained after installing the FC6 mysql package
instead of the RHEL5 package.

Comment 1 Tom Lane 2007-01-31 22:38:14 UTC
The x86_64 distro typically includes *both* sets of libraries, so that you can
run either 32 or 64-bit applications.  Are you sure this is a bug?

Comment 2 George Toft 2007-02-01 17:21:43 UTC
Just to be sure, I installed the package that came on the RHEL5 Public Beta 2 
CD and asked what it provides:
[root@rhel5xen2 php]# rpm -q --provides mysql
config(mysql) = 5.0.22-2.1
libmysqlclient.so.15
libmysqlclient.so.15(libmysqlclient_15)
libmysqlclient_r.so.15
libmysqlclient_r.so.15(libmysqlclient_15)
mysql = 5.0.22-2.1
[root@rhel5xen2 php]#


Then I removed it and installed the package from FC6:
[root@rhel5xen2 php]# rpm -ivh mysql-5.0.22-2.1.x86_64.rpm
warning: mysql-5.0.22-2.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 
4f2a6fd2
Preparing...                ########################################### [100%]
   1:mysql                  ########################################### [100%]
[root@rhel5xen2 php]# rpm -q --provides mysql
config(mysql) = 5.0.22-2.1
libmysqlclient.so.15()(64bit)
libmysqlclient.so.15(libmysqlclient_15)(64bit)
libmysqlclient_r.so.15()(64bit)
libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
mysql = 5.0.22-2.1
[root@rhel5xen2 php]#


The package includede in the RHEL5 PB2 x86_64 version does not have the 64 bit 
libraries for mysql client.

Perhaps this is was fixed in RC1?


Comment 3 George Toft 2007-02-01 17:24:46 UTC
I just noticed our CD was "pre-Beta2" not "pub-Beta2"  This may affect the 
outcome.

Comment 4 Tom Lane 2007-02-02 01:22:52 UTC
Hm ... well, if it is wrong, it's a rel-eng mistake not mine.  Bouncing over to
the appropriate component to see if the folks in charge of assembling the bits
think it's wrong ...

Comment 5 Daniel Mach 2011-01-04 15:28:04 UTC
I believe it's not a bug, definitely not in the latest RHEL 5.6 Snapshot, which contains both i386 and x86_64 rpms:
mysql-5.0.77-4.el5_5.4.i386.rpm
mysql-5.0.77-4.el5_5.4.x86_64.rpm

Testing didn't reveal any problems during installation, closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.