Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226422 - Merge Review: slrn
Summary: Merge Review: slrn
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
: 1160081 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:59 UTC by Nobody's working on this, feel free to take it
Modified: 2018-04-11 09:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-31 12:34:26 UTC
panemade: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:59:55 UTC
Fedora Merge Review: slrn

http://cvs.fedora.redhat.com/viewcvs/devel/slrn/
Initial Owner: mlichvar@redhat.com

Comment 1 Parag AN(पराग) 2008-01-15 12:34:20 UTC
1)good to have requires for -pull in following format
- MUST: In the vast majority of cases, devel packages must require the base
package using a fully versioned dependency: Requires: %{name} =
%{version}-%{release} 

rest packaging looks ok.


Comment 2 Miroslav Lichvar 2008-01-15 16:58:39 UTC
Ok, slrn-pull-0.9.8.1pl1-6.20070716cvs.fc9 has %{version}-%{release} in the
requirement.

Comment 3 Parag AN(पराग) 2008-01-16 04:02:09 UTC
Packaging looks ok now.
rpmlint gave me
slrn.i386: W: file-not-utf8 /usr/share/doc/slrn-0.9.8.1pl1/changes.txt
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).
==> This must be fixed. You can do this in next release.

slrn-pull.i386: E: non-standard-dir-perm /var/spool/slrnpull 0775
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

slrn-pull.i386: E: incoherent-logrotate-file /etc/logrotate.d/slrnpull
Your logrotate file should be named /etc/logrotate.d/<package name>.

slrn-pull.i386: E: setgid-binary /usr/bin/slrnpull news 02750
The file is setgid. Usually this is a packaging bug. If this is a game, 
then, you should use the proper rpm group, or location.

slrn-pull.i386: E: non-standard-executable-perm /usr/bin/slrnpull 02750
A standard executable should have permission set to 0755. If you get this
message, it means that you have a wrong executable permissions in some files
included in your package.

slrn-pull.i386: E: non-standard-executable-perm /usr/bin/slrnpull 02750
A standard executable should have permission set to 0755. If you get this
message, it means that you have a wrong executable permissions in some files
included in your package.

slrn-pull.i386: E: non-standard-dir-perm /var/spool/slrnpull/out.going 03777
A standard directory should have permission set to 0755. If you get this
message, it means that you have wrong directory permissions in some dirs
included in your package.

==> are those needed for this package?

Comment 4 Parag AN(पराग) 2008-01-27 14:32:04 UTC
ping?

Comment 5 Miroslav Lichvar 2008-01-28 15:28:55 UTC
Ok, converting the changelog and renaming the logrotate file is easy.

As for the permissions, I'm not really sure.

- /var/spool/slrnpull needs to be writable by news group.

- /usr/bin/slrnpull doesn't seem to need the setgid (it's supposed to be
executed under user news). 755 should be enough and it will also allow users to
run slrnpull.

- /var/spool/slrnpull/out.going needs to be writable by users allowed to post
articles which is now everyone. The directory needs to have setgid news to allow
slrnpull to remove the files.

Suggestions?

Comment 6 Parag AN(पराग) 2008-01-29 12:27:14 UTC
(In reply to comment #5)
> Ok, converting the changelog and renaming the logrotate file is easy.
 Ok.

> 
> As for the permissions, I'm not really sure.
> 
> - /var/spool/slrnpull needs to be writable by news group.
  Good to keep it then.

> 
> - /usr/bin/slrnpull doesn't seem to need the setgid (it's supposed to be
> executed under user news). 755 should be enough and it will also allow users to
> run slrnpull.

  I leave this upto you. 

> 
> - /var/spool/slrnpull/out.going needs to be writable by users allowed to post
> articles which is now everyone. The directory needs to have setgid news to allow
> slrnpull to remove the files.
  Good to keep it then.

When you update CVS, do comment here for review.

Comment 7 Miroslav Lichvar 2008-01-30 14:12:25 UTC
Committed to CVS.

Comment 8 Parag AN(पराग) 2008-01-31 04:30:09 UTC
Thanks for update.
Now rpmlint only have message
slrn-pull.i386: E: non-standard-dir-perm /var/spool/slrnpull 0775
slrn-pull.i386: E: non-standard-dir-perm /var/spool/slrnpull/out.going 03777

MUST:
   Sorry. I missed this => Source URL should be
http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
Look more on it at http://fedoraproject.org/wiki/Packaging/SourceURL



Comment 9 Miroslav Lichvar 2008-01-31 11:38:40 UTC
Source URL fixed.

Comment 10 Parag AN(पराग) 2008-01-31 12:31:44 UTC
thanks for CVS update.

APPROVED.

Comment 11 Petr Pisar 2014-11-04 07:18:00 UTC
*** Bug 1160081 has been marked as a duplicate of this bug. ***

Comment 12 Petr Pisar 2014-11-04 07:19:11 UTC
Matej, I'm not interested in epel7. If you want the package there feel free to request for the branch for yourself and to maintain it.

Comment 13 Matěj Cepl 2014-11-04 09:16:34 UTC
(In reply to Petr Pisar from comment #12)
> Matej, I'm not interested in epel7. If you want the package there feel free
> to request for the branch for yourself and to maintain it.

Most gladly

Package Change Request
======================
Package Name: slrn
New Branches: epel7
Owners: mcepl

Comment 14 Gwyn Ciesla 2014-11-05 11:35:33 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.