Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226390 - Merge Review: scim-anthy
Summary: Merge Review: scim-anthy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:54 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-16 13:00:22 UTC
mtasaka: fedora-review+
wtogami: fedora-cvs+


Attachments (Terms of Use)
mock build log of scim-anthy-1.2.2-1 on FC-devel i386 (deleted)
2007-03-09 08:11 UTC, Mamoru TASAKA
no flags Details
mock build log of scim-anthy-1.2.2-2 on FC-devel i386 (deleted)
2007-03-12 14:45 UTC, Mamoru TASAKA
no flags Details

Description Nobody's working on this, feel free to take it 2007-01-31 20:54:55 UTC
Fedora Merge Review: scim-anthy

http://cvs.fedora.redhat.com/viewcvs/devel/scim-anthy/
Initial Owner: tagoh@redhat.com

Comment 1 Mamoru TASAKA 2007-03-09 08:11:03 UTC
Created attachment 149671 [details]
mock build log of scim-anthy-1.2.2-1 on FC-devel i386

Merge review for scim-anthy 1.2.2-1

* URL
  Umm.. Is http://scim-imengine.sourceforge.jp/ hijached??
  
* Source URL
  - Source URL must be where we can directly download the source
    by "wget -N", for example.
    Currently Source0 points to only a HTML.

* Rebuild
  - Mock build fails (on FC-devel i386).
    * Note: making autoconf called after configure is done must
      be avoided.

* rpmlint
  A. For srpm:
----------------------------------------------------
A-1 W: scim-anthy mixed-use-of-spaces-and-tabs (spaces: line 3, tab: line 5)
----------------------------------------------------
     A-1 Minor issue, however, it is recommended to fix this.

  B. For binary rpm
----------------------------------------------------
B-1 E: scim-anthy obsolete-not-provided iiimf-le-canna
B-2 E: scim-anthy zero-length /usr/share/doc/scim-anthy-1.2.2/TODO
----------------------------------------------------
     B-1 _should_ be ignored IMO, because scim-anthy does not
	 actually provide iiimf
     B-2 would you explain why you want to include this empty file?

* Directory ownership
  - The following directories are owned by other packages
    required by this package.
----------------------------------------------------
/usr/share/scim  - by scim
/usr/share/scim/icons - by scim
----------------------------------------------------

* Timestamps
  - This package contains some 
    * text files (such as "*.sty")
    * image files (such as "*.png)
    and keeping timestamps on these files are recommended.
    Generally, 
----------------------------------------------------
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
----------------------------------------------------
    works (however currently I cannot test this because
    mockbuild fails as attached)

Comment 2 Akira TAGOH 2007-03-12 11:43:07 UTC
Thank you for reviewing.

(In reply to comment #1)
> Created an attachment (id=149671) [edit]
> mock build log of scim-anthy-1.2.2-1 on FC-devel i386
> 
> Merge review for scim-anthy 1.2.2-1
> 
> * URL
>   Umm.. Is http://scim-imengine.sourceforge.jp/ hijached??

Seems like that.

> * Source URL
>   - Source URL must be where we can directly download the source
>     by "wget -N", for example.
>     Currently Source0 points to only a HTML.

Fixed.

> * Rebuild
>   - Mock build fails (on FC-devel i386).
>     * Note: making autoconf called after configure is done must
>       be avoided.

Added autoconf to BR and invoked it before %%configure. it should works.

> * rpmlint
>   A. For srpm:
> ----------------------------------------------------
> A-1 W: scim-anthy mixed-use-of-spaces-and-tabs (spaces: line 3, tab: line 5)
> ----------------------------------------------------
>      A-1 Minor issue, however, it is recommended to fix this.

Fixed.

>   B. For binary rpm
> ----------------------------------------------------
> B-1 E: scim-anthy obsolete-not-provided iiimf-le-canna
> B-2 E: scim-anthy zero-length /usr/share/doc/scim-anthy-1.2.2/TODO
> ----------------------------------------------------
>      B-1 _should_ be ignored IMO, because scim-anthy does not
> 	 actually provide iiimf

Agreed. and it was actually intentional stuff.

>      B-2 would you explain why you want to include this empty file?

Assuming that it was not an empty file before, and becomes empty after that.
Removed.

> * Directory ownership
>   - The following directories are owned by other packages
>     required by this package.
> ----------------------------------------------------
> /usr/share/scim  - by scim
> /usr/share/scim/icons - by scim
> ----------------------------------------------------

Fixed.

> * Timestamps
>   - This package contains some 
>     * text files (such as "*.sty")
>     * image files (such as "*.png)
>     and keeping timestamps on these files are recommended.
>     Generally, 
> ----------------------------------------------------
> make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
> ----------------------------------------------------
>     works (however currently I cannot test this because
>     mockbuild fails as attached)    

Fixed.


Comment 3 Mamoru TASAKA 2007-03-12 14:45:33 UTC
Created attachment 149822 [details]
mock build log of scim-anthy-1.2.2-2 on FC-devel i386

* Build log
  - This time mockbuild is okay, except that autoheader
    is called after configure. IMO autoheader should be
    called in %prep stage, too.

Comment 4 Mamoru TASAKA 2007-03-12 14:47:03 UTC
Except my comment 3, everything is okay.

------------------------------------------
  The merge review of this (scim-anthy) is ACCEPTED by me.
------------------------------------------

Comment 5 Akira TAGOH 2007-03-13 13:31:47 UTC
Ok, fixed. thank you for reviewing.

Comment 6 Mamoru TASAKA 2007-03-16 13:00:22 UTC
Confirmed.

Comment 7 Jens Petersen 2007-05-17 07:13:53 UTC
Package Change Request
======================
Package Name: scim-anthy
New Branches: EL-4



Note You need to log in before you can comment on or make changes to this bug.