Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226344 - zsh init script /etc/zshrc must not source profile files
Summary: zsh init script /etc/zshrc must not source profile files
Keywords:
Status: CLOSED DUPLICATE of bug 126539
Alias: None
Product: Fedora
Classification: Fedora
Component: zsh
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:46 UTC by Daniel Qarras
Modified: 2018-04-11 07:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-31 23:55:52 UTC


Attachments (Terms of Use)

Description Daniel Qarras 2007-01-31 20:46:32 UTC
As mentioned in Bug 102187 (which I cannot reopen) it is wrong to source
/etc/profile or /etc/profile.d/*.sh from /etc/zshrc. That is already done in
/etc/zprofile and that is the correct place for such an operation. Sourcing the
files twice will override user's settings in ~/.zprofile.

Please see zsh man pages or consult zsh mailing lists if in doubt.

Thanks.

Comment 1 Matěj Cepl 2007-01-31 20:55:07 UTC

*** This bug has been marked as a duplicate of 102187 ***

Comment 2 Daniel Qarras 2007-01-31 21:14:01 UTC
Oh, a critical typo. I guess my complaints start to do more harm than good by
now but I was referring to a wrong bug, the one which talks about this problem
is Bug 126539.

Anyway, I'll leave this closed for now allowing you to check these things at
better time.

Sorry about the confusion.

Comment 3 Jens Petersen 2007-01-31 23:55:52 UTC
Bug 102187 was for RHEL.  Let's make this a Fedora bug and a duplicate of
bug 126539 and reopen that. :)


*** This bug has been marked as a duplicate of 126539 ***


Note You need to log in before you can comment on or make changes to this bug.