Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226291 - Merge Review: perl-XML-Simple
Summary: Merge Review: perl-XML-Simple
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:39 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-12 10:39:02 UTC
panemade: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:39:36 UTC
Fedora Merge Review: perl-XML-Simple

http://cvs.fedora.redhat.com/viewcvs/devel/perl-XML-Simple/
Initial Owner: rnorwood@redhat.com

Comment 1 Ruben Kerkhof 2007-07-01 20:53:34 UTC
It might be me, but I tried to checkout perl-XML-Simple, and the FC-5, FC-6, F-7 and devel branches are 
empty. The latest version is 2.14, in the FC-4 branch.

My CVSROOT is set to :ext:ruben@cvs.fedoraproject.org:/cvs/pkgs

Am I doing something wrong?

Comment 2 Robin Norwood 2007-07-02 13:40:36 UTC
I don't think you're doing anything wrong.  It looks like the package was in
extras pre-FC5, but was moved to core in FC5.  I'll request that the package be
added to those branches in CVS.  Thanks for catching this.

Package Change Request
======================
Package Name: 
New Branches: FC-5, FC-6, F-7, devel

Guys, some of the branches for this package were apparently lost when extras was
merged.  Perhaps because the package went from extras -> core.  I assume the
proper thing to do is request that it be added to those branches, like I did
above.  If not, please do whatever the right thing is.


Comment 3 Kevin Fenzi 2007-07-04 01:54:50 UTC
Odd. I see all those branches already there, but they are all completely empty. 
You should be able to import into them... or are you getting an error with that?

Comment 4 Robin Norwood 2007-07-04 04:24:07 UTC
After removing and re-checking-out perl-XML-Simple, I see FC-5, FC-6, F-7, but
no devel.  If you can create a devel branch, I can import a new srpm to those
branches.

Comment 5 Jason Tibbitts 2007-07-04 04:27:07 UTC
devel is there, but it's empty.  Make sure you aren't passing -p to your cvs
update (either on the command line or in .cvsrc) because if you pass -p then cvs
will delete the empty directory.

Comment 6 Robin Norwood 2007-07-04 14:40:07 UTC
That was it - I had:

update -d -P

in my .cvsrc

I had to remove the -P, but not the -d.


Comment 7 Robin Norwood 2007-07-04 16:17:22 UTC
ok, imported for F-7 and devel.  It should be there for you now.

Comment 8 Parag AN(पराग) 2007-10-22 09:17:38 UTC
1)perl as BR is not needed. mock build without it worked successfully.
   remove redundant dependency on perl >= 1:5.6.1


Comment 9 Parag AN(पराग) 2007-10-24 04:25:13 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
f6522514032092dd0341aa26a408ad4d  XML-Simple-2.17.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test outputs
  PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/0_Config........# ^M# Package                        Version
#  perl                           5.8.8
#  XML::Simple                    2.17
#  Storable                       2.15
#  XML::Parser                    2.34
#  XML::SAX                       0.16
#  XML::NamespaceSupport          1.09
#  XML::SAX::PurePerl             0.92
#  XML::LibXML::SAX::Parser       1.62
#  XML::LibXML::SAX               1.62 (default parser)
ok
t/1_XMLin.........ok
t/2_XMLout........ok
t/3_Storable......ok
t/4_MemShare......ok
t/5_MemCopy.......ok
t/6_ObjIntf.......ok
t/7_SaxStuff......ok
t/8_Namespaces....ok
t/9_Strict........ok
t/A_XMLParser.....ok
t/B_Hooks.........ok
All tests successful.
Files=12, Tests=485, 15 wallclock secs ( 3.22 cusr +  0.29 csys =  3.51 CPU)
+ Package perl-XML-Simple-2.17-2.fc8 ->
  Provides: perl(XML::Simple) = 2.17 perl(XML::Simple::FAQ)
  Requires: perl(:MODULE_COMPAT_5.8.8) perl(Carp) perl(Exporter)
perl(XML::Parser) perl(strict) perl(utf8) perl(vars)
+ Not a GUI app
APPROVED.


You can CLOSE this review as reviewed package is already in CVS.


Comment 10 Robin Norwood 2007-10-25 18:15:35 UTC
Ok.  Also updated to latest upstream version (2.18)

Comment 11 Parag AN(पराग) 2007-10-26 04:31:47 UTC
Thanks.
APPROVED for new release.
You can CLOSE this review as reviewed package is already built in rawhide.

Comment 12 Parag AN(पराग) 2007-11-11 07:04:26 UTC
Can we CLOSE this review if package is already built and in rawhide?


Note You need to log in before you can comment on or make changes to this bug.