Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226281 - Merge Review: perl-TermReadKey
Summary: Merge Review: perl-TermReadKey
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
: 516249 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:38 UTC by Nobody's working on this, feel free to take it
Modified: 2012-08-21 11:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-12 10:38:23 UTC
panemade: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:38:08 UTC
Fedora Merge Review: perl-TermReadKey

http://cvs.fedora.redhat.com/viewcvs/devel/perl-TermReadKey/
Initial Owner: rnorwood@redhat.com

Comment 1 Parag AN(पराग) 2007-10-20 12:42:33 UTC
1)perl as BR is not needed. mock build without it worked successfully.
   remove redundant dependency on perl >= 1:5.6.1
2)drop "|| :" from %check
3)rpmlint only complained ->
perl-TermReadKey.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.


Comment 2 Robin Norwood 2007-10-25 04:23:32 UTC
all issues above fixed.
Also added %{?dist} tag to release
New version is 2.30-3.fc9

Comment 3 Parag AN(पराग) 2007-10-25 05:39:47 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
f0ef2cea8acfbcc58d865c05b0c7e1ff  TermReadKey-2.30.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test outputs
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" -w test.pl
1 .. 8
ok 1
ok 2  # skip /dev/tty is absent
ok 3  # skip /dev/tty is absent
ok 4  # skip /dev/tty is absent
ok 5  # skip /dev/tty is absent
ok 6  # skip /dev/tty is absent
ok 7  # skip /dev/tty is absent
ok 8  # skip /dev/tty is absent
+ Package perl-TermReadKey-2.30-3.fc8 ->
 Provides: ReadKey.so perl(Term::ReadKey) = 2.30
Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) perl(:MODULE_COMPAT_5.8.8)
perl(AutoLoader) perl(Carp) perl(DynaLoader) perl(Exporter) rtld(GNU_HASH)

APPROVED.


Comment 4 Parag AN(पराग) 2007-11-11 07:04:16 UTC
Can we CLOSE this review if package is already built and in rawhide?

Comment 5 Iain Arnell 2009-08-08 09:16:16 UTC
*** Bug 516249 has been marked as a duplicate of this bug. ***

Comment 6 Marcela Mašláňová 2011-01-13 07:22:20 UTC
Package Change Request
======================
Package Name: perl-TermReadKey
InitialCC: perl-sig

Please add into CC perl-sig.

Comment 7 Jason Tibbitts 2011-01-13 17:24:16 UTC
Please don't include a change request if you're not going to include a proper one; it just confuses the scripts.  Simply raising the flag and describing what you need done should be sufficient.

I added perl-sig to all of the Fedora branches.

Comment 8 Petr Pisar 2012-08-21 11:20:21 UTC
Current package declares license `Copyright only'. However sources contains ppport.h which is `Artistic or GPL+' and which results into distributed shared library. Thus the package should declare `Artistic or GPL+'. I will fix it.


Note You need to log in before you can comment on or make changes to this bug.