Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 226278 - Merge Review: perl-SGMLSpm
Summary: Merge Review: perl-SGMLSpm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:37 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-12 10:36:43 UTC
panemade: fedora-review+
wtogami: fedora-cvs+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 20:37:46 UTC
Fedora Merge Review: perl-SGMLSpm

http://cvs.fedora.redhat.com/viewcvs/devel/perl-SGMLSpm/
Initial Owner: twaugh@redhat.com

Comment 1 Ondrej Vasik 2007-07-27 08:26:42 UTC
Package Change Request
======================
Package Name: perl-SGMLSpm
Updated Fedora Owners: ovasik@redhat.com

Comment 2 Parag AN(पराग) 2007-10-22 09:36:21 UTC
1)mock build went fine. But I saw rpmlint on RPM reported
perl-SGMLSpm.noarch: W: incoherent-version-in-changelog control 1.03ii-16.2.1
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.
==> remove string " sh: line 0: fg: no job control" from chnagelog

perl-SGMLSpm.noarch: W: invalid-license GPL
==> this looks to me as GPLv2

AND
rpmlint on SRPM reported
perl-SGMLSpm.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.
==>Use "sed -i -e 's|\t|  |g' perl-SGMLSpm.spec"


2) You can add disttag (not mandatory)
3) drop "|| :" from %check
4) mock build worked for me after remove BR: perl 



Comment 3 Tim Waugh 2007-10-22 10:04:27 UTC
Oops, I was trying to reassign this to the new package owner.

Comment 4 Ondrej Vasik 2007-10-22 11:31:05 UTC
Ok, thanks for review, there were no bugs against this package, so I haven't
found  some of those errors earlier:
1)sh:line 0 string will be removed - error caused by JKeating script in last build
2)License should be GPLv2+ as there is nowhere written that the license is
exactly GPLv2 
3)dist tag will be added
4)I think whole %check section is not necessary, so will be deleted
5)BR for perl will be removed as not necessary

Corrected version built as perl-SGMLSpm-1.03ii-16.3.fc9



Comment 5 Parag AN(पराग) 2007-10-22 11:50:16 UTC
Thanks for quick update.
Still I can see rpmlint on SRPM as
perl-SGMLSpm.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

Also,
  It will be good to add documentations. Can you also add those files?

Comment 6 Ondrej Vasik 2007-10-22 13:21:34 UTC
ok, indents will be fixed and COPYING and README file shipped. I think this is
enough, there is more documentation in the tarball, but I don't want to increase
size of package too much. What do you think about that? (I will wait with koji
build for a while to prevent more unnecessary commits and builds)

Comment 7 Ondrej Vasik 2007-10-25 13:48:22 UTC
Ok, waited 3 days for comments, this should be enough, commited with fixed
indents and base documentation. Built as perl-SGMLSpm-1.03ii-16.4.fc9.

Comment 8 Parag AN(पराग) 2007-10-26 05:37:47 UTC
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
5bcb197fd42e67d51c739b1414d514a7  SGMLSpm-1.03ii.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package perl-SGMLSpm-1.03ii-16.4.fc8  ->
  Provides: perl(SGMLS) perl(SGMLS::Output) perl(SGMLS::Refs)
perl(SGMLS_Attribute) perl(SGMLS_Element) perl(SGMLS_Entity) perl(SGMLS_Event)
perl(SGMLS_Notation)
  Requires: /usr/bin/perl openjade perl(:MODULE_COMPAT_5.8.8) perl(Carp)
perl(Exporter) perl(SGMLS) perl(SGMLS::Output)

APPROVED.




Comment 9 Parag AN(पराग) 2007-11-11 07:04:08 UTC
Can we CLOSE this review if package is already built and in rawhide?

Comment 10 Ondrej Vasik 2007-11-12 09:46:37 UTC
I think that you should close the ticket when you feel satisfied with changes -
from my point of view it can be closed as RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.